Support » Plugin: Inline Google Spreadsheet Viewer » I'm Sure I'm an Idiot But Can't Get Rid of Google Login

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Meitar

    (@meitar)

    What shortcode did you use?

    [gdoc key =”https://docs.google.com/spreadsheets/d/15qm9HFFMTlYEW3yb3MbV1m7BwlRoiNYY5s_riVACGSY/edit?usp=sharing”]

    Plugin Author Meitar

    (@meitar)

    That should do it. I just confirmed that Google is redirecting you to a login page, though I’m not sure why.

    The plugin works by requesting the CSV version of your Sheet. In your case, that’s this address: https://docs.google.com/spreadsheets/d/15qm9HFFMTlYEW3yb3MbV1m7BwlRoiNYY5s_riVACGSY/export?format=csv

    As you can see when you follow that link while signed out of your Google Account, you get redirected to a login page. That’s why you’re seeing the login page. But I don’t know why Google is redirecting your export to a login page.

    It’s possible that Google recently made some change to their APIs, but if they have, I haven’t heard about it.

    I’d suggest you double-check all possible google export settings/restrictions and see if you can get to that export URL (the one I pasted above) in your browser. The expected result is that your browser will prompt you to save your spreadsheet as a CSV file download.

    You may also want to ask about this on the Google product support forums.

    TL;DR:

    As far as I can tell, your shortcode is fine, your Sheet is shared publicly, so I can’t find a problem with what you’re doing. Maybe there’s a misconfiguration in your sheet’s sharing settings? Maybe? If there is a change in how Google has started routing requests of this type, I want to know about it, so please share what you find out with me.

    Thanks for the speedy response and confirmation that I am not crazy. If I find anything out I will let you know. Thanks for the help.

    Hi Abylander and Meitar,

    I think I figured out what happened here. The same thing happened to my google sheet, and then I changed the setting in google docs.

    1 – Go to share settings

    2 – Click on advanced

    3 – Make sure to unclick disable options to download, print, and copy for commenters and viewers

    4 – Click save, the google docs login should not appear

    Sincerely
    Jon

    Plugin Author Meitar

    (@meitar)

    Thanks Jon.

    Sorry not working!.

    Hey there,

    I was having the same problem but I was able to get it to work by changing the sharing options to:

    LINK SHARING:
    ON – Anyone With link can view.

    ACCESS:
    Anyone can edit.

    This took away the login prompt for me. Though this definitely is not the way I’m sure most of us would like to have gone about it. But it seems that exporting as CSV is now considered editing…

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘I'm Sure I'm an Idiot But Can't Get Rid of Google Login’ is closed to new replies.