Support » Plugin: UnGallery » I'm not stupid, but I just can't get Ungallery to work any more!

  • I actually had ungallery working when I first installed the plugin, but now can’t get it to work for the life of me! I’m good with linux…
    Also I can’t seem to create the cache….even though I have changed the permissions, and tried several directories on my server…

    my absolute path I am trying right now is:

    (yes I have the trailing slash)

    this is the one that is suggested to me in the ungallery admin page:


    My page wordpress:

    My portfolio I’m trying to use with Ungallery:

    Weird thing is that it worked perfectly when I first installed it, but since trying to point it to a different directory, nothing seems to work! Must be something I’m doing wrong…

    Thanks for any suggestions,


    btw: great work with this plugin! I love simple, do it yourself systems like this. No interfaces or other b.s. Just a folder! excellent Mark…Maybe I should upgrade to 3.2?

Viewing 5 replies - 1 through 5 (of 5 total)
  • update: sorry I have been messing with this and now my image directory is:

    Plugin Author mmond


    Hi Trevor,

    Could you provide an example image filename that is in your target image directory? I can use it to test UnGallery’s access to display the image.


    Hi Mark,

    the two image files I have in the target directory are:


    Here’s the first error I’m getting on my portfolio page:

    Warning: opendir(/home/thewr798/public_html/blog/wp-admin/portfolio/) [function.opendir]: failed to open dir: No such file or directory in /home/thewr789/public_html/blog/wp-content/plugins/ungallery/ungallery.php on line 119

    I’ve got the ~wp-admin/portfolio/ permissions to 777 as well as the cache. I have tried creating cache directories at:

    I’ve played with the permissions on ~wp-content/plugins/ungallery/ and the ungallery.php but that was just me guessing…

    Thanks Mark, I just can’t figure this out…

    Plugin Author mmond


    No problem. Thanks for the info and sorry for the glitches.

    You found at least one bug regarding the cache directory. UnGallery does not properly handle the root of the WordPress (/blog) being different than the root of the web site ( I’ll try and correct that separately. In the meantime, the caching issue should affect the pictures actually loading, just the speed of reloading.

    One other point. The suggested cache and photo directories are not in the wp-admin hierarchy. That is used on the admin page to show the general path. Probably a better target for photos is either the wp-content hierarchy or even better, outside the web server directories, somewhere like /home/thewr798/pics/. I’ll clarify the instructions on the admin page.

    It may help us to try a directory like above to remove both possible permission and pathing issues. It could be that a permission of one of the parent directories is the issues.


    K thanks! Ill tru that and let ya know. By the way, my wordpress sie will be moved to the root ( instead of when my WP site is all finished, so that shudnt be a problem.
    Thanks again!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘I'm not stupid, but I just can't get Ungallery to work any more!’ is closed to new replies.