Support » Plugin: Mollie for Contact Form 7 » I’m not redirected to the Mollie payment environtment

  • Resolved AdmireNL


    Password for page url is ‘test’.

    I’m not redirected to the Mollie environtment for the actual payment, I’m just seeing the succesful form submit message from CF7 and that’s it, nothing more. What am I doing wrong?

    I’ve implemented the Mollie fields as shown below.
    The amount field value is filled by Javascript after calculating the sum of all chosen options.

    Totaalbedrag: € [text amount id:total readonly]
    [hidden paymentdescription "Bestelling Kerstontbijt 't Veerhuys"]
    [submission_id_hidden submission_id-777 orderid]
    Betaalmethode [paymentchoice paymentmethod paymenttype:oneoff default:1]
    Kies uw bank [bankchoice bankchoice]

    Shortcode for the CF7 form implementation:

    [payment_result success = "Uw betaling is gelukt" fail = "Uw betaling is niet gelukt. Probeer opnieuw s.v.p."]
    [contact-form-7 id="1210" title="Kerstontbijt"]
    • This topic was modified 4 months, 1 week ago by . Reason: typos and additions

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter AdmireNL


    Plugin Author tsjippy


    That is because you redirect to another page,, in my case. If you remove that it should work

    Thread Starter AdmireNL


    Thanks for looking into it. That redirection is what Contact Form 7 automatically does. Actually it’s not a different page, just a hash is added by CF7. I think it’s default CF7 behaviour.

    The “wpcf7-f1210-p1213-o1” is called the “unit tag” and is indeed part of the default form action URL. However, you wouldn’t see it after form submit usually.

    The redirect doesn’t happen because loading CF7 scripts has been disabled by the theme or a plugin. We just resolved this issue in the Contact Form 7 add-on for the Pronamic Pay plugin, so you will be redirected to the payment page even if scripts are disabled.

    Thread Starter AdmireNL


    Thanks Reüel. I forgot that I indeed intercepted plugin styles and scripts, because I didn’t want the default. However, by enabling everything, the redirect is indeed removed, but I still am not forwarded to the Mollie environment. I’ve switched to the Mollie Forms plugin now, but thanks for the effort.



    I have the same problem, I also I’m not redirected to the Mollie payment environtment.
    Can you have a look for me?

    I have this in my contact form 7.

    [hidden paymentdescription “Betaling Voetbalkamp Voorjaarseditie 1 dag”]

    Aanbetaling Voetbalkamp 1 dag
    [amount* Betalingsbedrag min:50 max:50 “50”]

    <label> Jouw bank
    [bankchoice bankchoice-22]</label>

    [paymentchoice paymentmethod-364 paymenttype:oneoff]

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.