Support » Fixing WordPress » I’m having trouble naming the Pages.

  • Resolved EDG


    I’m a little confused about how the pages are named:

    See –

    If I go to the dashboard and look under Settings/Reading, it’s set to “Front Page displays… your latest posts”. This means that (from the left to right) I’ve got a “Blog” page, a “Home” page, an “Our Products” page, and a (blank) “News” page there.

    However, I want to change this so that the “Home” page is the first tab shown on the left, the second tab is a “News” page containing the blog articles, and the third tab is the “Our Products” page. I get how to change the order (just change the number in the Order field, right?), but when I try (in Settings/Reading) to set the Front Page to a static (Home) page and the News Page to the News page, I don’t get that. Instead, I get the leftmost tab called “Blog” but showing the contents of the “Home” page, the second tab is “News” and shows the blog contents, and the third page is “Our Products” (which is actually correct).

    So it’s almost right when I change it to static pages, but I’m unable to rename the “Blog” tab to “Home” which is what it should be (Obviously I don’t want a Blog page and a News page). Is there a way to do this? I couldn’t find any way to change it in the css for the theme, but surely there’s some way to do it?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Ah, I figured it out, though it seems really kludgy.

    I found an option in the “k2 Options” to rename the “Blog” tab. However, if I want the Home tab to be first, I have to rename the Blog tab to “Home”, and then set the Front Page to be Home, and the News page to be News. Only then can I get the Home page showing up first, then the News page (with blog articles), then the Our Products page.

    Now the only problem is that I can’t rename the URLs for the pages – the news page for example is news-4, and if I edit the link to remove the “-4” it just resets back to news-4 again. Anyone know how to fix that? I’ve tried removing my previous attempts to make news pages from the trash but I still can’t change it.

    OK, got that link issue sorted – it wasn’t let me change the URLs because I’d set the News page as a static page. Once I unchecked that, I could change the URL and then set it back as a static page again.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘I’m having trouble naming the Pages.’ is closed to new replies.