WordPress.org

Ready to get started?Download WordPress

Forums

Twenty Thirteen
I'm going crazy - featured images always get cropped (3 posts)

  1. thescarletfire
    Member
    Posted 1 year ago #

    No matter what I do, I can't get the featured images of my blog posts to just be the size they are - they keep getting cropped down. It's so frustrating, can someone tell me how I can stop this?

    I have a child theme already, so I'm trying to figure out what code is needed to change this :( I'm going crazy.
    I don't know how to override the parent functions.php for that one section of code below (I get an error when I leave both in the files).

    What's causing this in the default 2013 theme?

    Thank you!

    I think it's involving this:

    * This theme uses a custom image size for featured images, displayed on

    * "standard" posts and pages.

    */

    add_theme_support( 'post-thumbnails' );

    set_post_thumbnail_size( 604, 270, true );

  2. Thomas McMahon
    Member
    Posted 1 year ago #

    Check your media options page /wp-admin/options-media.php

    There you can set the thumbnail size and corp options.

    To have it the original size, set the thumbnail size to something like 9999.

    Test that and see if it works.

    Note: These settings work on a go forward, not on previous posts. You'll need to re-upload and re-set featured images for those.

  3. thescarletfire
    Member
    Posted 1 year ago #

    Ah, thank you! I will try this. I appreciate you helping.

    S

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.