Support » Plugin: WooCommerce Cloak Affiliate Links » I’m getting 404 on all the cloaked links

  • Resolved vbergara

    (@vbergara)


    Hi, I just installed this plugin and it replaced the external links but every link now results in a 404 page, in my domain (by that I mean that the page linked to exists, but it seems that the cloaked link wasn’t set up properly in my domain).

    I tried leaving the “Affiliate link base” option the default and also tried changing it, but it still gives me a 404 error.

    Edit: I think it’s worth mentioning that my wordpress installation is in a subfolder in the root. This might have something to do with it, I guess.

    Edit2: Okay, I just confirmed that that is the problem.
    My site is mysite.com
    My wordpress ins installed in mysite.com/wp/
    The cloaked links are pointing to mysite.com/wp/redirect/12345
    But it should be mysite.com/redirect/12345
    If I try this last option it works. How can I configure the plugin so it ignores the subfolder?

    • This topic was modified 8 months ago by  vbergara.
Viewing 4 replies - 1 through 4 (of 4 total)
  • vbergara

    (@vbergara)

    For now, I edited your woocommerce-cloak-affiliate-links/class-wccal-product-external.php file and replaced the get_site_url() method call to a literal with my website’s url. But I’d appreciate a better solution to this. Thanks.

    Plugin Author datafeedr

    (@datafeedrcom)

    Can you try this? Can you replace get_site_url() with home_url() and let me know if that works for you?

    Thanks
    Eric

    vbergara

    (@vbergara)

    That worked perfectly, thanks! The plugin is great, btw.

    Plugin Author datafeedr

    (@datafeedrcom)

    Thanks for checking. I updated the code and now 1.0.7 has this change in it.

    Thanks again
    Eric

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘I’m getting 404 on all the cloaked links’ is closed to new replies.