WordPress.org

Support

Support » Plugins and Hacks » Contact Form DB » I'm geting error when I try to connect to google spreadheet live data

I'm geting error when I try to connect to google spreadheet live data

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Michael Simpson

    @msimpson

    #ERROR! suggests that the script is not installed or has some error. Hard to know specifically. I can only suggest to try to install the script in the spreadsheet again. Open the script editor, delete everything and re-copy it in fresh.

    I tried, still nothing ..
    but .. I read about the addon can cause problems … my site is an addon… olso I use better wp security .htaccess most secured level…

    What do you think?

    Regards
    Peky

    Plugin Author Michael Simpson

    @msimpson

    I don’t know.

    @batapeky, any news for this issue ?
    Did waiting for live data “update” solve the problem ?
    I’ve just installed and configured the extension and my spreadsheet but I ran in the same problem… So I’ll wait as said here.

    @5amsan
    I don’t think that waiting solves this issue… This scenario I do not see every day without solution..

    Tonight i will install only cf7 & contact-form-7-to-database-extension on my fresh wp installation to see what will happen.. if works then I try to install other plugins one by one, in doubt that they can cause a problem..

    ..if you can try this earlier, let me know the result.

    thanks
    batapeky

    First thing to fix : I use a custom folder install, so my “siteUrl” passed to the first function should be ‘http://mysite.com/my_wp_folder’

    So, did you import the data in the spreadsheet successful..?

    … I tried to make the same steps in other my sites and nothing new, still the same error in analysis..
    ..

    Peky

    Nop, no success… I’m screwing the google script around… Think I’ll go and see deeper in the plugin now.

    Ok,
    Now I manage to get my results correctly but only if I declare variables in Google Script, hardcoded. Variables seem to get lost from spreadsheet to GS…

    Ok. what is the variable that needs to be put in Code.gs..
    .. how to declare?

    Are you solve the issue?

    Peky

    I work on it this morning. Tell you more about soon.

    OK all good, finally it looks like using single quotes in a formula for passing variables is a bad idea.
    I loaded all datas once using hardcoded vars, then passing vars in double quotes got it to work properly.

    In code has been wp-login.php I change the line 62 to var url = siteUrl + “/myloginphrase?redirect_to=wp-admin/admin-ajax.php%3Faction%3Dcfdb-export%26form%3D” + encformName;

    ( is this right ? )

    I have the hidden admin.. 🙂
    ..Now is pulling something, login ok..

    [ Moderator Note: Please post code or markup snippets between backticks or use the code button. ]

    <!DOCTYPE html>
    <!--[if IE 8]>
    <html xmlns=
    <![endif]-->
    <!--[if !(IE 8) ]><!-->
    <html xmlns=
    <!--<![endif]-->
    <head>
    <meta http-equiv=
    <title>Dashboard ‹ My site.com - My site name — WordPress</title>
    <script type=
    addLoadEvent = function(func){if(typeof jQuery!=
    var userSettings = {
    "		'url': '/'"
    "		'uid': '3'"
    "		'time':'1351682367'"
    "	}"
    "	ajaxurl = '/wp-admin/admin-ajax.php'"
    "	pagenow = 'dashboard'"
    "	typenow = ''"
    "	adminpage = 'index-php'"
    "	thousandsSeparator = '"
    "	decimalPoint = '.'"
    "	isRtl = 0;"
    </script>

    ….
    ..and so, up to nearly 400 rows.. i suppose that now pulling the data from somewhere..

    My formula still is =CF7ToDBData(“http://www.mysite.com/”, “Contact form 1”, “”, “myusername”, “mypassword”)

    @5amsan did you saw this when you trying to make it work?
    … From where pulling this data? What about single quotes ?

    Sorry, but I barely have time to deal with this, so thank for your help.
    …what do you suggest to do now?

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘I'm geting error when I try to connect to google spreadheet live data’ is closed to new replies.
Skip to toolbar