Support » Plugin: Yoast SEO » Illegal string offset warning after upgrade to 11.1

  • Resolved craigjwillis

    (@craigjwillis)


    I’ve disabled the plugin now so the error doesn’t show on the link. But after I upgraded the plugin today to 11.1 I now get an error that reads

    Warning: Illegal string offset ‘width’ in /plugins/wordpress-seo/frontend/schema/class-schema-image.php on line 149

    Get another message about height on line 150.

    Thanks

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support benvaassen

    (@benvaassen)

    Hi there,

    I’m sorry to see you have these warnings show up on your website. They shouldn’t show up and we shouldn’t create them. The warnings on your frontend should go away if you disable WP_DEBUG in your wp-content.php.

    I’m trying to reproduce the warnings, yet I’m unable to do so with a default theme, like Twenty Nineteen. Can you report this issue on GitHub so we can prevent these warnings? Link to GitHub: https://github.com/Yoast/wordpress-seo/issues?

    I use Yoast Premium and have the same problem. The WP_DEBUG is disabled in the wp-config.php but the problems stays. I currently see it on more WordPress websites. I finally turned off the Yoast plugin. That may not be the intention, I hope.

    Plugin Author Taco Verdonschot

    (@tacoverdo)

    Hi @jeanlortye,

    We’re pretty sure we’ve found the source of the warning. Given that it’s just a warning, and nothing breaks on your website, we won’t be issuing a patch release immediately.

    However, if you see the warning on the front-end of your site and not just in your log files, this looks a lot like a configuration issue with your server. https://aristath.github.io/blog/wp-hide-php-errors is a helpful resource to help you resolve this.

    Hello Taco, thank you for your quick response. It is indeed only a warning but such an error message disrupts our website. I have replaced ‘define (‘ WP_DEBUG ‘, false)’ for

    ini_set (‘display_errors’, ‘Off’);
    ini_set (‘error_reporting’, E_ALL);
    define (‘WP_DEBUG’, false);
    define (‘WP_DEBUG_DISPLAY’, false);

    and that means that I no longer see PHP messages on the front. So problem solved!

    I have the same issue. Warning is displaying on the frontend

    @jeanlortye I tried your fix but the errors are still displaying on the front end. Has anyone else found a fix for this issue? Although it’s a warning, displaying it on the front end of our website is certainly an issue.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.