WordPress.org

Forums

Customizr
[resolved] Illegal offset type in isset or empty in post.php after upgrade to custom3.1.20 (14 posts)

  1. mlakey130
    Member
    Posted 11 months ago #

    Upgraded Customizr to 3.1.20, running Woocommerce 2.1.12, all plugins disabled. Receive error when going to base 'Shop' page.

    Illegal offset type in isset or empty in /../../../wp-includes/post.php on line 1078

    Saw another post about same error and response was to add:
    add_filter('tc_include_cpt_in_archives' , '__return_false' );

    Did not solve my issue. Any help? Thanks.

  2. jammin138
    Member
    Posted 11 months ago #

    Yeah, me too.

  3. nikeo
    Member
    Theme Author

    Posted 11 months ago #

    Hi @mlakey130 and @jammin138, thanks for reporting this bug.

    I have tried to reproduce the issue and I had no problem.
    The demo site of Customizr uses Woocommerce 2.1.12 with a shop page : http://demo.themesandco.com/shop/
    There's no warning or notice when I activate the deubg mode.

    Can you please check and report :
    1) which version of WordPress do you use
    2) If you have specific customizations in your functions.php (iether functions, filter, actions) that could be in conflict with the theme? (other than your plugins)

    Thanks and I look forward to reading from you

  4. jammin138
    Member
    Posted 11 months ago #

    Hi Nikeo,

    I'm not using Woocommerce but I am using a directory plug-in from WPMU. If i change the theme to say 2014 then everything works fine.

    When I click on a link on my home page using the customizr theme some go to a blank page and some go to a page with this;

    Warning: Illegal offset type in isset or empty in /home/content/p3nexnas06_data03/01/2160401/html/wp-includes/post.php on line 1078

    I'm running wordpress 3.9.2

    Hope this help, I'm new to all of this so please let me know if you need anything else, or if I've missed something;-)

    Thanks,
    Ben

  5. jammin138
    Member
    Posted 11 months ago #

    oh, and I've put this code into a CSS manager

    .dr_list_grid li {
    width: 29%;
    }

    .article-container{width:100%}

    Not sure if that helps?

    Thanks again

  6. nikeo
    Member
    Theme Author

    Posted 11 months ago #

    Hi @jammin138,
    please contact me with this form, I will need to investigate deeper your website.
    Thanks.

  7. jammin138
    Member
    Posted 11 months ago #

    Hi Nikeo,

    I've just sent the form off.

    Many thanks,
    Ben

  8. mlakey130
    Member
    Posted 11 months ago #

    Hi Nikeo,
    Wordpress version is 3.9.2. No mods to functions file at all. I disabled all plugins in an attempt to track down. Tried twenty-twelve theme and did not receive error.
    url: artwarehouse.biz/shop

    Thanks, Mitch

  9. nikeo
    Member
    Theme Author

    Posted 11 months ago #

    Hi @mlakey130, this will be fixed in the next release of the theme.
    Thanks for reporting the issue.

  10. mlakey130
    Member
    Posted 11 months ago #

    Thanks @nikeo, any idea when next release will be available?

  11. nikeo
    Member
    Theme Author

    Posted 11 months ago #

    Hi @mlakey130, it's available here for download.
    Best

  12. mlakey130
    Member
    Posted 11 months ago #

    Many thanks @nikeo!

  13. carolmurchie
    Member
    Posted 11 months ago #

    Had the same problem and now it's fixed, @nikeo. Thanks, I really like working with your Customizr theme for this reason. Cheers!

  14. nikeo
    Member
    Theme Author

    Posted 11 months ago #

    Great, happy to help :-)

Reply

You must log in to post.

About this Theme

About this Topic