Support » Fixing WordPress » IIS7 Plugin Hell

  • palmtek

    (@palmtek)


    Using IIS7, PHP 5.3, and can’t update plugins. I’ve added IUSR to the Plugin folder, then to the Content folder, then to the whole dang site with modify rights but still can’t update plugins. When I do try to update a plugin I get this;

    Unpacking the update…
    
    Installing the latest version…
    
    Removing the old version of the plugin…
    
    Could not remove the old plugin.
    
    Plugin update failed.

    Not only does the plugin fail, but it is no longer in the full list of plugins, not even disabled, not even there anymore. I have to reinstall it.

    This has been going on this way for many months and I keep revisiting this issue trying to see if someone out there has some wisdom on this. Anyone who can put the answer to this on their blog is going to have a bonanza of hits with it. I see a lot of chatter on the matter but no solutions.
    Thanks for a little help,
    – Cory

Viewing 8 replies - 1 through 8 (of 8 total)
  • sofaking21

    (@sofaking21)

    Here’s my preferred method: run your application pool under a service account. Then, make sure that anonymous authentication uses the application pool identity instead of impersonating IUSR. Then, set up all your NTFS (and share permissions if you’re using DFS or some other network share) for the service account. I only allow full permissions for the wp-content folder; everything else is read/execute.

    palmtek

    (@palmtek)

    sofaking21, Thanks.
    I’m not sure how to change the application pool setting. I’ve never messed with it before. The rest of it I get. Any pointers?

    palmtek

    (@palmtek)

    I found what you are talking about.
    Set Application Pool Defaults/Process Model/Identity
    It didn’t fix the problem but thanks for the effort.

    sofaking21

    (@sofaking21)

    Is this a production environment? I’d run PROCMON and monitor where it’s failing. It really sounds like a permissions issue to me.

    palmtek

    (@palmtek)

    I have a test site that I’m working in to find the problem. It’s some kind of issue with IIS’s caching. After I try to run an update, the plugin folder of the plugin I try to update is locked in a way that I can’t even open it. If I restart IIS then I can.

    palmtek

    (@palmtek)

    Yep! Caching.
    I highlighted my test site, opened “Output Caching”, Clicked “Edit Feature Settings” on the top right, and unchecked both boxes. I restarted IIS and I was able to update plugins after that.
    There are those of you who’d say “Just use Ubuntu”, and you’d be right, but where’s the challenge in “Set it and forget it”?
    Case closed.
    – Cory

    palmtek

    (@palmtek)

    You can leave Kernel Caching on.

    palmtek

    (@palmtek)

    This link has the correct answer. I haven’t tried it this way with caching turned back on though.
    http://www.pmdconsulting.biz/blog/plugin-upgrade-failed-in-wordpress-using-iis-7/

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘IIS7 Plugin Hell’ is closed to new replies.