Support » Plugins » IIS 6 doesn’t work wiht any Plug-ins?

  • I can’t get any plugins to work on WordPress(2.1.2) in IIS 6.0. WordPress 2.1.2 itself seems to work fine. I attempted to install several plugins unsuccessfully. Each time it appeared that references to code in other directories under the website root could not be executed.

    For example one of the plugins had a drop down box on a form that enabled you to choose a language – the code behind it accessed a directory called “lang” that allowed a list of different languages to be chosen. The functionality of the drop down list didn’t work and was blank. Similar occurrences happened with other plugins. I’ve tried everything I could to make any work.

    Out of desperation to troubleshoot, and with no mind for security, I have even tried:
    1. Giving both the <sitename>_Anon and < sitename >_Admin user accounts both full access rights to all files and directories in the website
    2. Giving the IUSR_<servername> user account full access rights all files and directories in the website.
    3. Giving the user group IIS_WPG full access rights to the entire website, files\directories.
    4. Gone into IIS MMC and enabled Directory Browsing through out the website.
    5. Going into the PHP.INI and adding a doc_root reference to the parent website directory.

    It appeared to be a security issue with not being to traverse directories at first. Then I thought it was an issue of processes in IIS 6 could not be kicked off. After trying all the above now I’m not so sure now. Any advice would be helpful.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The above server has:
    W2k3 server SP2
    IIS 6
    MySQL 5.0.37
    PHP 5.2.1
    WordPress 2.1.2

    Tried plugins:

    OK – now I’m really confused. I’ve successfully installed WordPress on Apache and I still can’t get any plugs to work. Maybe it wasn’t an IIS issue? Now I will look at other commonalities, so the commonalities between an IIS install and an Apache Install are what? I’m guessing I need to review the PHP.ini and httpd.conf file? I don’t think the MySQL install would have anything to do with a plugin problem. PHPMyAdmin and MySQL Administrator both work fine. Tomcat works fine. Several Virtual sites are configured and they come up fine. What else should I be looking for? How do you test why plugins won’t work?




    I’m curious. You said you “can’t get any plugins to work” but you’ve listed only two. Have you tried a **simple** plugin, such as the hello dolly plugin?

    Sorry about that. I was so irritated I let my emotions get the best of me. Any plugin that has to have access to other subdirectories within the WordPress site – hasn’t worked. Hello Dolly works fine but it doesnt make any calls to code in other directories.

    I have now installed WordPress in both Apache 2.2.4 and IIS 6.0 and in both instance WordPress seems to work fine. But in both instances the plugins I tried (that have to have access to code in other directories) fails.

    It almost sounds like a “DocumentRoot” problem but in each virtual website I did define the Document root in the virtual-hosts.conf file.

    The default website for the local server uses this:
    DocumentRoot “D:/Program Files/Apache Software Foundation/Apache2.2/htdocs”

    The virtual sites use this:
    DocumentRoot “D:/Websites/www.<sitename>.org”

    My httpd.conf file also has:
    DocumentRoot “D:/Program Files/Apache Software Foundation/Apache2.2/htdocs”

    I am really at a loss, that is why I’m going to uninstall PHP5 and try PHP4. Time will tell I guess.




    Youre doing all of this on a box using NTFS?

    Now that we have a little clarification, and its NOT exactly true that you “can’t get any plugins to work”….

    I would say that this is a Windows issue and NOT a WordPress issue. You are undeniably going to disagree, but thats OK.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘IIS 6 doesn’t work wiht any Plug-ins?’ is closed to new replies.