Support » Plugin: W3 Total Cache » Ignoring dynamic file Paths with wildcard.

  • Resolved Nate1

    (@nate1)


    We have been having issues using Elementor where the file isn’t being combined properly into the minified file. Subsequent loads and cache clearing appears to fix the issue, however I would like to avoid it altogether by ignoring files matching the dynamic elementor path.

    Entering works correctly and avoids caching.
    wp-content/uploads/elementor/css/post-15144.css

    However I need to implement the following path
    wp-content/uploads/elementor/css/post-*
    to ensure it works on all pages – but it doesn’t seem to work? Is there anyway to do this?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @nate1

    I am sorry about the issue you are experiencing and I am happy to assist you with this. The “*” wildcard cannot be used in “Never cache following JS/CSS files” filed. For example if you add wp-content/uploads/elementor/css/* or
    wp-content/uploads/elementor/css/*.css it will not work (not intended to work this way)
    You can either add the files one by one to exclude them from minify, or you can switch to Manual minify and add the CSS files manually and in order and of course, simply do not add that file to minify.
    Thank you!

    Hi Marko.
    You wrote one year ago that regex in minify exclusions would be available in the next release https://wordpress.org/support/topic/wildards-in-minify-exclusions/ I don’t understand why it still doesn’t work.
    Divi generates JS files with unpredictable unique identifiers that I need to exclude from minifying to make the site working. I need a wildcard or a regex to exclude the directory wp-content/et-cache/
    Thank you.

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @bndn

    Sorry for the later reply.
    Yes, this was in the testing process but since then developers turned the attention the other way.
    I understand that this could help a lot and simplify the process and we’ll make sure to turn our attention to this.
    Thank you!

    Thread Starter Nate1

    (@nate1)

    Hello, a workaround which appears to help a lot – but not completely resolve issue was to exclude resources (with elementor external css enabled) from minification with the following.
    I haven’t had time to thoroughly check through the issues, but it appears that it may not be just an issue with minification, the code below definetly helps but It seems to be rather buggy when w3Tc is enabled – with two purges being required to allow a rendered item to show – Often one page will work but another page in a menu for example will not render correclt. I think both plugins are well worth while so would be awesome if they played nicely together. Could an extension like the Yoast extension work for adding the appropriate items?

    `function filter_w3tc_minify_css_do_tag_minification( $do_tag_minification, $style_tag, $file ) {
    if($do_tag_minification && isset($file) && strrpos ( $file , “elementor” ) >= 1){ return false; }
    return $do_tag_minification;
    };
    add_filter( ‘w3tc_minify_css_do_tag_minification’, ‘filter_w3tc_minify_css_do_tag_minification’, 10, 3 );

    function filter_w3tc_minify_js_do_tag_minification( $do_tag_minification, $script_tag, $file ) {
    if(strrpos ( $file , “elementor” ) >= 1){ return false; }
    return $do_tag_minification;
    };
    add_filter( ‘w3tc_minify_js_do_tag_minification’, ‘filter_w3tc_minify_js_do_tag_minification’, 10, 3 );

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Ignoring dynamic file Paths with wildcard.’ is closed to new replies.