Support » Plugin: iframe » iFrame suddenly showing example from plugin page

  • Resolved antipole

    (@antipole)


    I have been using this plugin for years to display a Google map. My short code is the following, except I am showing it here with round brackets rather than square (in case square brackets trigger some short code on this site):

    (iframe height=”600″ src=”https://blog.antipole.co.uk/blog/uploads/blog-charts/2016-19/Whole_Baltic_track.html”)

    Sometimes and certainly today, the iFrame shows something else, namely the iTube video as in the example at the start of the plugin description here.
    Examining the code with the web inspector, I see:
    <iframe 0="height=&quot;600&quot;&nbsp;src=&quot;https://blog.antipole.co.uk/blog/uploads/blog-charts/2016-19/Whole_Baltic_track.html&quot;" src="https://www.youtube.com/embed/4qsGTXLnmKs" width="100%" height="500" scrolling="yes" class="iframe-class" frameborder="0"></iframe>
    That is the src parter has been replaced with src=”http://www.youtube.com/embed/4qsGTXLnmKs” as on the plugin description.

    So has my site been hacked? I have SSL turned omn so the page is secure. I have no other evidence of a security issue. If it had been hacked, why would the hacker display the example content from the plugin description rather than something of benefit to him/her? The coincidence seems too much. Is it some plugin failure? Any ideas, please?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author webvitalii

    (@webvitaly)

    Hi @antipole

    Dont worry. Your website is not hacked. The video is the placeholder if something is wrong with shortcode parameters. You probably had an extra quote in the SRC URL.

    I tried this shortcode and it worked for me:

    [iframe height="600" src="https://blog.antipole.co.uk/blog/uploads/blog-charts/2016-19/Whole_Baltic_track.html"][/iframe]

    Please try to paste it one more time and see if it works for you.

    • This reply was modified 3 months, 3 weeks ago by webvitalii.
    • This reply was modified 3 months, 3 weeks ago by webvitalii.

    It was odd. The iFrame had been working fine and then suddenly stopped after I had edited the page title. I have just been back to it and spotted WordPress said there was a more recent save of the page. I restore that and all is well again. It seems I had an imperfect save of the page, which must have messed up what the plugin was seeing. I have seen this before.

    Maybe it would be helpful if the plugin displayed an error message if there is something wrong with the parameters?

    Anyhow, thank you for your help.

    I think I understand the problem. Sometimes the page gets saved with an escaped space within the shortcode. This displays the place holder. Example:
    [iframe height="600"&nbsp;src="https://blog.antipole.co.uk/blog/uploads/blog-charts/2016-19/Whole_Baltic_track.html"]
    Editing the escaped space back to a real space fixes the problem.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.