Support » Plugins and Hacks » [Resolved] Iframe not loading? No form showing up.

[Resolved] Iframe not loading? No form showing up.

  • My Pardot contact form iframe doesn’t seem to be loading any content. I can access the iframe URL directly and I see the javascript code, so the problem does not appear to be the actual iframe page, rather the content that page is supposed to generate.

    I have cleared the Pardot cache.
    I have deactivated and reactivated the Pardot plugin.
    I have cleared the Pardot cache again.

    I have been making some CSS changes to the site, but I don’t see how that could break the JS running on Pardot’s servers within an iframe on my site.

    Any suggestions?


Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Cliff Seal


    Thanks for posting!

    I’m not sure what you’re referring to when you say “I see the javascript code”, as your iframe URL should be loading the HTML from your form. Do you have a live URL you can share, or, can you email me at cliff dot seal at pardot dot com?

    Thanks! We’ll get you fixed up right away.

    Live URL: http://www.newforma.com/

    Iframe URL: http://www2.newforma.com/l/7852/2012-10-10/37981j – I didn’t set up this website or Pardot account/plugin. I’m just supporting it now. I’m not sure if that matters or not.

    When I inspect the site, I see the iframe, but there’s nothing in it but javascript. I assume that JS is supposed to be generating the contact form.

    The form worked perfectly as recently as this morning.

    Plugin Author Cliff Seal


    I’m checking into it, but this appears to be coming from the Pardot side of things, not the plugin itself. I’ll report back shortly.

    Plugin Author Cliff Seal


    I see. The layout template that the client is using on the form is blank! We’ll need to fix that up within Pardot—can you check with them to see if that was changed recently?

    I can give you more details and guidance at the email above. I’m going to resolve this particular topic for now to be clear to others.

    I will ask, thank you.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Iframe not loading? No form showing up.’ is closed to new replies.