WordPress.org

Support

Support » How-To and Troubleshooting » iFrame code disappears in WP2.5.1

iFrame code disappears in WP2.5.1

  • Am frustrated as iFrame code is disappearing in 2.5.1

    Have had this with a Google Map insert on one blog, and now on a second blog I am trying to insert an iFrame to an external page and it doesn’t appear.

    there are 2 plugins that I tried:
    PageView, but didn’t want the description and needed to specify dimensions

    and

    lifoFrame… but this just shows the coding in HTML view and no iFrame.

    Has something changed in 2.5.1. Are iFrames being blocked like at wordpress.com?

    Help!

Viewing 4 replies - 1 through 4 (of 4 total)
  • iFrame code will function properly until you return to edit the page. If you make any changes anywhere on the page, WordPress 2.5.1 eats the iFrame code. This is different that 2.5.0, which scrambled the code, rendering it useless.

    If you make all your changes, then set your iFrame code, then save (or publish) the iFrame works. You have to do it all over again if you ever have to edit that page again.

    I am finding the same thing and it is very annoying. This never happened until I upgraded to 2.5.1.

    Is there any fix for this?

    Never use the visual editor if you are adding your own code.

    Hey guys,

    I edited my page and put a iframe in it.
    http://blog.stefansegers.nl/?page_id=83

    During edit mode you won’t see it. But when I save it will appear.
    My next problem is that my iframe stays the same with and height.

    I can’t change it’s width and height

    Here’s my code

    <iframe src=”http://www.oypo.nl/pixxer/api/templates/0801.asp?id=588978BBC1FEF593&css=http://www.oypo.nl/pixxer/api/css/0801.css&nonav=0&opties=fotomail,”
    name=”pixxerframe” id=”pixxerframe”
    width=”100%” height=”500″
    marginwidth=”0″ marginheight=”0″
    frameborder=”0″
    scrolling=”auto”>
    </iframe>
    <!– verwijder de regel hieronder indien je de hoogte van het iframe handmatig instelt –>
    <script src=”http://www.oypo.nl/pixxer/api/iframeheight.js” type=”text/javascript” language=”javascript”></script>

    I hope somebody can help me out?

    Stef

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘iFrame code disappears in WP2.5.1’ is closed to new replies.
Skip to toolbar