Support » Plugin: Stop Spammers Spam Prevention » If you use comcast, you can't install this plugin

  • My dynamic IP address starts with 24.x.x.x – installed your plugin (version 4.0, WP 3.4.2), went to activate it and received this error:

    [code]Plugin could not be activated because it triggered a fatal error.

    Reason code: sbl.spanhaus:153,2,24
    ip: 24.x.x.x[/code]

    I x’ed out my current IP address for obvious reasons. So I went to the spamhaus website, discovered that the entire 24.0.0.0/12 block of IP addresses is listed in their PBL database. I’m unable to remove my address from that list, site would not allow it.

    So I took a look at your code, and found this in stop-spammer-registrations.php…

    [code] $iplist = array(
    ‘sbl.spamhaus’ => ‘.sbl.spamhaus.org’,
    ‘xbl.spamhaus’ => ‘.xbl.spamhaus.org’,
    ‘dsbl’ => ‘.list.dsbl.org’,
    ‘sorbs’ => ‘.dnsbl.sorbs.net’,
    ‘spamcop’ => ‘.bl.spamcop.net’,
    ‘ordb’ => ‘.relays.ordb.org’,
    ‘njabl’ => ‘.dnsbl.njabl.org’
    [/code]

    and I commented out each spam database site one by one. Every single spam site listed in your plugins array considers 24.0.0.0/12 as a spam source. That is a significant number of comcast internet users. I would have to comment out that entire array list to be able to activate this plugin, and in doing so would defeat the purpose of said plugin.

    Suggestions? 🙂

    http://wordpress.org/extend/plugins/stop-spammer-registrations-plugin/

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘If you use comcast, you can't install this plugin’ is closed to new replies.