Support » Plugin: latch » If you are concerned with your WP security this plugin is a must!

  • Best security plugin for WordPress PERIOD!.
    Nobody could possibly access your wordpress install, even if he or she finds out your password.

  • The topic ‘If you are concerned with your WP security this plugin is a must!’ is closed to new replies.