WordPress.org

Forums

WordPress HTTPS (SSL)
If search results include an https page, the /?s=xxx part of the URL is doubled (5 posts)

  1. cblack
    Member
    Posted 3 years ago #

    WP HTTPS v3.3.6

    The URL of the search results page looks like this:
    https://site.com/?s=keyword?s=keyword

    And the results match:
    "keyword?s=keyword", not just "keyword"

    I've read a bit about this issue in other situations, but not in relation to the search URL. I tried adding "/?s=" to the url filters section and it does nothing.

    The only option I have ticked is Force SSL Exclusively.

    The bug goes away when I add "/" to the url filters, but I don't want my entire site secure.

    Thanks in advance for anyone who can help.

    http://wordpress.org/extend/plugins/wordpress-https/

  2. Mike Ems
    Member
    Plugin Author

    Posted 3 years ago #

    Hmm, not a clue. Could you try the development version and let me know if the issue persists?

  3. cblack
    Member
    Posted 3 years ago #

    The development version has the same bug. I'll leave it active for another hour if you want to see what it's doing. http://www.lewermark.com (search for "id card").

    The first two results are the only https pages on the site. The bug only occurs when one or both of these pages are included in the search results.

  4. Mike Ems
    Member
    Plugin Author

    Posted 3 years ago #

    Alrighty, I'll update this topic when I have a fix to try. I can't reproduce it, so I'm just kind of shooting in the dark, haha. Thanks for trying it.

  5. cblack
    Member
    Posted 3 years ago #

    Installing the "Nice Search" plugin solved the issue.

    It replaces the query string "/?s=search+term" with "/search/search+term".

    Thanks for the effort.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress HTTPS (SSL)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic