Support » Plugin: BJ Lazy Load » If scroll fast, images fail loading

Viewing 14 replies - 1 through 14 (of 14 total)
  • with retina images is even worst 🙁

    Plugin Author Bjørn Johansen


    What OS and browser are you using? I’ve tried a few times in different browsers, but don’t get the same results as you are describing.

    Firefox on Mac, but I’ve spoken with the server administrator and they say it’s an Apache memory problem. It seems your plugin is memory demanding maybe

    this file is listed in the server’s error log
    (12)Cannot allocate memory: […] /wp-content/plugins/bj-lazy-load/thumb.php

    Plugin Author Bjørn Johansen


    Image processing needs a bit of memory, yes. Unfortunately, there’s nothing I can do about that.

    If you increase the memory_limit value in your php.ini, your problem should be fixed. Just out of curiousness, what is it currently at?

    I can’t ;(
    currently it seems to be at 128M

    But I dont’ know if it comes from that. I’ve set 64M on my local server, disabled browser cache and everything works fine

    another issue I’ve spotted with the lazyload : my images are 100% wide and has no height or width in html output.

    I have the feeling when your lazy load is on, the images get a sort of 0 (or something small) height. That means as I scroll, a huge number or images starts loading, making the lazyload less useful and not fluid. any fix for that?
    This issue happens on an iPhone, but not in a desktop browser…

    Hi Bjørn,
    deactivating both retina and responsive options the site work better (no out of ram).

    However I notice lazyload doesn’t kindly fade-in images at 1st load, but only the 2nd when they’re (I suppose) in the browser cache.

    And lazyload does not work on Safari!!

    Plugin Author Bjørn Johansen


    Deactivating those options will help you, as you won’t have to do any special processing of the images.

    You are correct on the fadein. This will be changed in an upcoming release.

    It works very well in Safari for all my sites – can you provide me with more details?

    temporarily reactivated the plugin just to let you see
    In Safari/Chrome on mac all imgs load. Please tell me when seen to let be disable it.

    Plugin Author Bjørn Johansen


    I see what happens, and this is my guess:

    You havent defined height (or width) for your images. At document.ready all images are within the viewport, because the first images doesn’t take up the space that would push the rest «below the fold».

    If you define the height/and with for your images, I bellieve the issue should be fixed.

    I see, but I need them without because of a liquid layout.
    Thanks anyway 🙂

    Plugin Author Bjørn Johansen


    You can still keep the width/height attributes, just add this (or similar) to your CSS:

    img {
      max-width: 100%;
      height: auto;
Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘If scroll fast, images fail loading’ is closed to new replies.