Support » Plugin: WDContactFormBuilder » Needs Advanced Configuration

  • Difficult to configure if you’re not very tech savvy. I couldn’t get submissions from anyone using gmail, hotmail, yahoo, etc.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Sona


    Hi Aadezero,

    Thanks for your feedback.

    However please be aware that mailing sending issue may be caused by your hosting.

    – WordPress uses PHP mail. Perhaps your hosting does not have sendmail enabled. Please contact your hosting provider.
    – Alternatively, you can use SMTP, which should always work.

    You can use this plugin for example:
    Setting up an external SMTP server, such as GMail should work. But GMail requires authentication.

    Mailer: smtp
    SMTP Authentication: yes
    SMTP Security: SSL
    SMTP Port: 465
    SMTP Username: your gmail full address
    SMTP Password: your gmail password
    SMTP Host:

    Instructions for WP SMTP
    Please be informed, that this could be an issue with your server. You can check this by the following way. Please install an SMTP plugin, e.g. WP SMTP ( and send a test mail to your e-mail in its settings. If the e-mails will be sent, then the issue is within Form Maker and we will need temporary full admin access to take a look at the problem.

    But if the test mail will fail being sent, then the issue is within your website’s mail server and you’ll need to contact your hosting provider to solve the problem.

    Thread Starter adezero


    Wouldn’t an inbox inside of the plugin be useful? Then you could just skip the SMTP config part.




    To avoid any kind of conflicts with other plugins using mail services, we are sticking with standard WordPress email send_out function. And if this doesn’t work, it is 99% issue coming from a hosting provider. In some rare cases it is caused by other plugin. In any case the plugin doesn’t have email settings and thus the issue is not related to the plugin itself.

    I hope this helps you to get overall idea of the reasons behind using WordPress native option instead.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Needs Advanced Configuration’ is closed to new replies.