WordPress.org

Forums

Responsive
[resolved] IE9 WP Responsive Theme Header (8 posts)

  1. lisandrom
    Member
    Posted 3 years ago #

    I have an issue with WP Responsive theme and IE9.

    It was working like a charm, but suddenly the menu appears at the very top of the website, you can see it here:

    http://nomina123.net/ (the menu is appearing at the right of the logo in IE9), but in FF, Chrome and other browsers it works fine.

    I am using a customized version of responsive WP theme.

    I tried to undo everything I have done, including the removal of the submenus, changes I have done in styles and so on with no luck.

    Also I tried to add the following:

    <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

    to the header... no luck.

    I was trying to "debug" the problem in IE9 using the F12 feature and disable one by one all the css styling for menu and menu-item related classes with no success, the menu persist at the top.

    A desperate measure would be to restore the full site to the last stable version, but it is a multisite, so this is not an easy work to do, and probably too desperate for a single styling.

    Any help?

    Txs

  2. Andrew Nevins
    Forum moderator
    Posted 3 years ago #

    Add;

    .main-nav {
     clear: both;
    }
  3. esmi
    Forum Moderator
    Posted 3 years ago #

    Try asking on the theme's dedicated forum: http://cyberchimps.com/forum/free/responsive/
    You may get a faster & more informed response there.

  4. lisandrom
    Member
    Posted 3 years ago #

    Txs Andrew, it works.

  5. rretana2013
    Member
    Posted 2 years ago #

    What file do i add the main-nav code and after what line of code?

  6. WPyogi
    Forum Moderator
    Posted 2 years ago #

    You can ADD to custom CSS under theme options - assuming you are using Responsive theme.

    For additional help, see the link esmi posted above for the Responsive forums. This thread is long outdated so may not be relevant any longer.

  7. rretana2013
    Member
    Posted 2 years ago #

    Thanks that was fast, but I have tried to fix this issue and no luck. The person who created the websites created a Responsive Child Theme and modified so many stuff, which I don't see the logo or the navigation bar don't display correct in IE.

  8. WPyogi
    Forum Moderator
    Posted 2 years ago #

    I'd suggest you post your own thread on the forums linked to above and include a link to your site so someone can help you with it - this thread is marked resolved and it's unlikely your situation/site is identical to the OP's.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags