WordPress.org

Support

Support » How-To and Troubleshooting » IE9 issue (I have searched and tested before posting!)

IE9 issue (I have searched and tested before posting!)

  • Hi guys,

    I run http://www.dawes.co.nz and have a template that is a few years old, but functional. Only in IE9 do I get this behaviour and using compatibility mode is a temp fix – however that’s not good enough for my readers.

    Whenever my contact form is clicked, or other parts, the background goes black and can’t see the content. I have consulted the mighty internet, added stuff like:

    <meta http-equiv=”X-UA-Compatible” content=”IE=8″> to the header – no difference.

    <?xml version=”1.0″ encoding=”UTF-8″> as the very 1st line, broke the site

    Can anyone offer any advice of where to go next please? I have searched and tried everything to date to force compatibility mode but it doesn’t seem to make a difference.

    Help me Obiwan – you’re my only hope!
    Mike

Viewing 15 replies - 1 through 15 (of 15 total)
  • esmi

    @esmi

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    Yes I have, the behaviour is indicative of the lightbox plugin, when you click a photo for example it would show the image and darken the background, but it’s on every click of stuff and I can’t see anywhere to disable lightbox or equivalent.

    Cheers

    Moderator Andrew Nevins

    @anevins

    Forum moderator

    Only in IE9 do I get this behaviour and using compatibility mode

    Which version of Internet Explorer are you replicating in compatibility mode?

    esmi

    @esmi

    Forum Moderator

    Try deleting the lightbox plugin.

    Sorry to confirm

    If I use IE9, I get the fault
    If I use IE9 and click the Compatibility mode button I don’t.
    It works in Chrome
    It works in FF
    Don’t have Safari but presume ok

    Moderator Andrew Nevins

    @anevins

    Forum moderator

    I’m using IE9 and this darkened background also occurs when clicking elsewhere on the page.

    I don’t seem to have a lightbox plugin to delete, either in the console or the dir on server – if it’s bundled in the template I have no idea how to uncouple it

    Andrew, but if you hit the little broken page button it works after reloading yeah?

    Moderator Andrew Nevins

    @anevins

    Forum moderator

    Yes Dawesinnz,
    But there is clearly a serious issue and success in compatibility mode should not defer this.

    esmi

    @esmi

    Forum Moderator

    Try switching to the Twenty Eleven theme to confirm that it’s a theme-specific problem.

    If I switch, when I switch back will my widgets and sidebar content just come back or does it all have to be reset?

    esmi

    @esmi

    Forum Moderator

    Your theme’s settings and widgets will have been retained in your database. They should activate immediately as soon as you switch back to the old theme.

    Think I have fixed it – Took out the line:

    <link rel=”stylesheet” type=”text/css” href=”<?php bloginfo(‘template_url’); ?>/assets/css/lightbox.css” />

    From header and works ok, tested on pages and all displaying ok.

    Took a backup of the file just inacse.

    Thanks for taking the time to assist

    Mike

    Moderator Andrew Nevins

    @anevins

    Forum moderator

    Your lightbox may no longer work where once was necessary.

    That’s fine, I didn’t like that feature anyway

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘IE9 issue (I have searched and tested before posting!)’ is closed to new replies.
Skip to toolbar