Support » Alpha/Beta/RC » IE7 menu problems with 3.0 beta 2

  • perthmetro

    (@perthmetro)


    I have a StudioPress theme (lifestyle classic NOT a genesis child theme). I can’t get the menu to work properly in IE7 but IE8 is fine???

    This is what I have …
    <?php wp_nav_menu( array('menu' => 'TopMenu' )); ?>

    this is the website (see how the menus work in IE7!!
    http://sandgroper.net/scafinancedemo/

Viewing 9 replies - 1 through 9 (of 9 total)
  • esmi

    (@esmi)

    Forum Moderator

    You might want to consider conditional comment CSS.

    perthmetro

    (@perthmetro)

    so it’s a theme IE7 issue not a 3.0 issue?

    esmi

    (@esmi)

    Forum Moderator

    I think it’s probably the result of IE7’s flawed CSS box model.

    perthmetro

    (@perthmetro)

    Curse Microsoft!

    perthmetro

    (@perthmetro)

    It’s not dupe thread as I thought it just didn’t work on this particular theme in IE7… the other post asked if it was an IE7 issue in general?

    Still love to know!

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    So try it on the 2010 theme on your box? I don’t have IE 7 so I can’t test. Works fine on Chrome and Firefox and Safari. Fails on IE 6 but then again, I didn’t expect it to work 😉

    perthmetro

    (@perthmetro)

    good idea… watch this space

    perthmetro

    (@perthmetro)

    TwentyTen menu works fine in IE7

    Actually, NO. TwentyTen does not work fine in IE7.

    The dropdown menus break in you go below one level. Specifically, if you mouse over the child menu options and then mouse off…..and then return.. the last hover stays open, but with no links…just the link bg color. Also, the menus z-index is off in ie7.

    This is with a fresh, clean install of wordpress…so please dont tell me to validate my code. This def a problem that is not being addressed.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘IE7 menu problems with 3.0 beta 2’ is closed to new replies.