WordPress.org

Forums

IE shows site as mobile-version! (15 posts)

  1. Kettercat
    Member
    Posted 1 year ago #

    Hey everyone,

    I'm using the theme Mystile (not from the WordPress directory) on my site. For some reason, IE shows the site as the mobile version! It looks great on other browsers though.

    What could be the reason? The staff behind the theme don't know what could be the reason. I tried removing all the changes I'd done and reinstalling the theme from scratch, the same thing happens.

    This is the link:
    http://ronnies-linux.evh732.evhost.co.il/

    What do I do? :(

  2. sardst
    Member
    Posted 1 year ago #

    have you tried to clear cookies and browser's cache?

  3. Kettercat
    Member
    Posted 1 year ago #

    Hey sardst! Yes - but it happens in every computer I've tried (been dealing with it for about a month now)

  4. Andrew
    Forum moderator
    Posted 1 year ago #

    You using a version of IE less than 9? Or are you in some sort of compatibility mode (press f12)?

  5. Kettercat
    Member
    Posted 1 year ago #

    Happens on both IE8 & IE9 (I need to cover IE8 too as many of the visitors still use that)

  6. Andrew
    Forum moderator
    Posted 1 year ago #

    Then I would contact WooThemes about this http://www.woothemes.com/

  7. Kettercat
    Member
    Posted 1 year ago #

    They said they don't know what could be the problem as it doesn't happen when they try to install the theme and to reinstall it. Tried that, same thing happens :(

  8. Andrew
    Forum moderator
    Posted 1 year ago #

    And this issue is specific to your theme?

  9. Kettercat
    Member
    Posted 1 year ago #

    Yep, when I switch to a different theme it's all good.

  10. Andrew
    Forum moderator
    Posted 1 year ago #

    So the main issue is that WooThemes aren't providing you with support for their theme?

  11. Kettercat
    Member
    Posted 1 year ago #

    Oh no, they're okay, I've been nagging them for ages :) They've been trying hard to find the problem but they can't figure it out. That's why I thought maybe someone knows what could trigger it...

  12. Andrew
    Forum moderator
    Posted 1 year ago #

    If the theme is responsive and if it has been built in a certain way then it's probably using Media Queries for all of its screen sizes apart from mobile.

    Old Internet Explorer browsers don't recognise Media Queries by default and so people on those browsers will only see the mobile styles because all other styles are in Media Queries.

    Have you considered switching to a theme on WordPress.org: http://wordpress.org/themes/ ? We support those.

  13. Kettercat
    Member
    Posted 1 year ago #

    Thanks Andrew! That probably explains it. Even though their demo shows up well on IE, but I figured out it must be the @media tag.

    Thanks a lot though! My client is asking for Mystile, I'll try to convince her to switch to something else.

    Thanks!

  14. johnfotios
    Member
    Posted 1 year ago #

    Yeah, old I.E doesn't understand CSS media queries, try using PHP instead?

  15. Kettercat
    Member
    Posted 1 year ago #

    Hey johnfotios, how can I use PHP to fix this?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags