Support » Fixing WordPress » IE prob: footer gets taller, when cursor hovers over links in body

  • Resolved JoseChung


    Hey there!

    Bit of a weird phenomenon here, and I can’t isolate the cause. Possibly it’s a bug with my browser only, but we’ll see if you guys can replicate the issue.

    In IE, if you visit my site, scroll to the bottom of the page and hover your cursor over any link that isn’t part of the footer… voila, suddenly the footer’s background gets taller. Scroll up and then back down… voila, the footer background is back to normal.

    If you scroll up, so that the footer is out of sight, and then hover over a link… when you scroll back down, the footer looks fine. What the heck?

    I’ve been through my stylesheet to make sure I’ve closed everything that needs closing, and it seems to be fine… but chances are I’m missing something. I’ve also cleared IE’s temp files/cache/cookies etc, in case it’s a prob with my IE only. Didn’t seem to help.

    Hopefully I’ve described the problem clearly.

    Thoughts? My site-in-development:

Viewing 2 replies - 1 through 2 (of 2 total)
  • vkaryl


    It’s probably padding somewhere – IE isn’t good with padding on internal elements. And sometimes it’s not even padding in, say, the footer – can even be the header….



    Thanks for the suggestion, vkaryl.

    I went through my stylesheet, adjusting assorted padding settings, to see which one was the culprit. Ultimately it didn’t fix the problem, but the proces inspired me to go right through the stylesheet, systematically commenting out chunks one by one, until I found the culprit that was screwing up my footer. Weirdly, it turned out to be these lines:

    hr {
    display: none;

    Go figure. So I’ve kept that commented out, and it has solved my initial footer problem, but it has also thrown a couple of other things out of whack. So I’ll tinker a bit, but from here on it seems to be pretty much under control.

    Thanks again!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘IE prob: footer gets taller, when cursor hovers over links in body’ is closed to new replies.