WordPress.org

Support

Support » Themes and Templates » Preference Lite » [Resolved] IE and Opera Not Displaying Properly

[Resolved] IE and Opera Not Displaying Properly

  • I’m not sure why, but my page is not centering in Opera. The main sections (aka background) are centered, but the text does not take the full width of the section and sits on the left of the container. It looks fine in IE, Firefox, Chrome, and Safari, and when the page size is reduced.

    The second issue is how the bottom menu appears in IE. I have 4 pages linked, in 4 separate widgets. All other browsers, these are side by side and it comes up how it should. But in IE, the first column has 2 menu sections, the second none and the third and fourth show up normally with only one (though the links are pushed to the side).

    Here’s my site: slroselaw.com

Viewing 14 replies - 1 through 14 (of 14 total)
  • Moderator Andrew Nevins

    @anevins

    Forum moderator

    Can you state the browser versions that the issues occur in?

    I’m using IE 9.0, and Opera 12.15.

    Moderator Andrew Nevins

    @anevins

    Forum moderator

    Look at resolving your validation errors.

    Going through it now. So far, it’s fixed the IE error. Thank you.

    Where would the HTML files be located? It’s giving me the errors in HTML, and showing me the code but I thought everything was done with PHP instead.

    Moderator Andrew Nevins

    @anevins

    Forum moderator

    First try deactivating plugins to explore whether any could be responsible.

    I deactivated all the plugins not directly used for my site. If I had an HTML area, I could fix the errors it’s giving me, but don’t know enough without HTML to fix the errors.

    Theme Author Styled Themes

    @gejay

    I just dropped by this thread and I’m assuming things are working OK now? I just looked in IE10 (also in ie9 mode) and it looks ok. The validation that Andrew posted does need attention though. Most of the errors of:

    The center element is obsolete. Use CSS instead

    …are the use of <center> which is no longer used. One solution is to put your links into a div container with some inline styling to center it like this:

    <div style="text-align: center;"><a href="http://slroselaw.com/about/">About our Firm</a></div>

    It’s working great now on IE. However, Opera is still not taking the width of the page on a large screen size properly.

    Theme Author Styled Themes

    @gejay

    I will have to add Opera to my list of browsers and test this out (and for future themes). Is it possible to take a screenshot of what your page looks like in Opera?

    Here is how the page looks in Opera:
    http://i40.tinypic.com/ih04us.jpg

    Theme Author Styled Themes

    @gejay

    Thanks for the screenshot. I just downloaded and installed Opera version 12.15 (the latest) and I went to your website. I was not able to replicate what you show in your screenshot as you can see with this one I did:


    Screenshot using Opera v12.125

    Not sure why yours is showing a shortened content area and aligned left. Have you tried clearing your browser’s cache?

    That worked. Must have just been my browser. Not sure why it did that, as I’d just downloaded a clean version of Opera to test how the website appeared. Thanks, such an easy “fix”!

    Theme Author Styled Themes

    @gejay

    Awesome! I’m happy to hear that worked. Caching is nasty sometimes.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] IE and Opera Not Displaying Properly’ is closed to new replies.
Skip to toolbar