Support » Plugin: Fourteen Extended » IE 8

  • I have the latest plugin version which I used to remove the left sidebar and therefore menu and that looked very nice under Firefox, Chrome. Then I tried IE8 on my old XP box only to find that the left sidebar had reappeared and now contained the navigation. ie the top primary menu disappeared to become the secondary menu. A massive gap has also appeared at the top of pages/posts.

    The total width of the site is 1260px and I have set it as a child theme as I needed to remove the category headings from category.php.

Viewing 7 replies - 1 through 7 (of 7 total)
  • PS I have copied the ie.css over from the parent theme BTW and added the following coding:

    function mytheme_dequeue_styles() {
       wp_dequeue_style( 'twentyfourteen-ie' );
     add_action( 'wp_enqueue_scripts', 'mytheme_dequeue_styles', 11 );
    //add new from child theme
    wp_enqueue_style( 'mytheme-ie', get_stylesheet_directory_uri() . '/css/ie.css', array( 'twentyfourteen-style' ), '1.0' );
    $wp_styles->add_data( 'mytheme-ie', 'conditional', 'lt IE 9' );
    Plugin Author Brian Harris


    Unfortunately I don’t have access to a machine with IE8 for testing at the moment and therefore was unaware of that issue. Could I ask you to right click to view the source code then copy it and paste it in a pastebin so that I can take a look at what is going on?

    A massive gap has also appeared at the top of pages/posts.

    Could you test without the plugin and take screenshots of both? – There is a gap by default generated from the parent theme so would need to see the difference in gap size.

    An update version of the plugin is coming up shortly that has an option to remove the default gap.

    Can I ask if the IE issue is resolved by the function you pasted? I’m guessing some adjustments are needed in the default IE CSS too?

    Thanks for the input and feedback,

    Thanks for your prompt response – sorry I was out yesterday.

    I have copied the HTML and also screen dumps for the three cases: 2014 child theme with plugin, 2014 child theme on its own and 2014 parent theme.

    The child theme is very simple – I have just removed the “Category Archives” line in category.php, modified the footer in footer.php added the above function into functions.php and the following style.css:

    Theme Name: Twenty Fourteen Child
    Template: twentyfourteen
    @import url("../twentyfourteen/style.css");

    I also added the complete css directory from the parent which contains ie.css and editor-style.css but this doesn’t make any difference either.

    Is there a better way to get the HTML and .gif images to you? Reply privately if you want. The latter are quite big because they include the header image.

    BTW this is the dump from theme-mods-twentyfourteen-child in the option table:

        [0] =>
        [header_textcolor] => blank
        [background_color] => ffffff
        [background_image] =>
        [background_repeat] => repeat
        [background_position_x] => left
        [background_attachment] => fixed
        [nav_menu_locations] => Array
                [primary] => 4
                [secondary] => 0
        [featured_content_layout] => slider
        [header_image] =>
        [header_image_data] => stdClass Object
                [attachment_id] => 976
                [url] =>
                [thumbnail_url] =>
                [height] => 178
                [width] => 1260
        [fourteenxt_center_site] => 1
        [fourteenxt_primary_menu_float] => left
        [fourteenxt_hide_left_sidebar] => 1
        [fourteenxt_overall_content_width] => 1038
        [fourteenxt_fullwidth_blog_feed] => 1
        [fourteenxt_fullwidth_single_post] =>
        [fourteenxt_fullwidth_archives] =>
        [fourteenxt_fullwidth_searches] =>
        [fourteenxt_content_off_featured_image] =>
        [fourteenxt_content_width_adjustment] => 874
        [fourteenxt_feed_cat] => 0
        [fourteenxt_home_excerpts] =>
        [fourteenxt_excerpt_length] => 55
        [fourteenxt_fitvids_enable] =>
        [fourteenxt_fitvids_selector] => .post
        [fourteenxt_fitvids_custom_selector] =>
        [fourteenxt_featured_visibility] =>
        [fourteenxt_enable_autoslide] =>
        [fourteenxt_slider_width] => 1600
        [fourteenxt_slider_height] => 500
        [fourteenxt_slider_topmargin] => 0
        [fourteenxt_featured_bg_visibility] =>
        [fourteenxt_maximum_site_width] => 1260
        [fourteenxt_overall_image_height] => 572
        [fourteenxt_content_top_padding] =>
        [fourteenxt_sidebar_top_border] =>
        [fourteenxt_body_class_filters] =>
        [fourteenxt_layout_mobile] => grid
        [fourteenxt_slider_transition] => slide
    Plugin Author Brian Harris


    No problem.

    For the screenshots please post in the plugin’s dedicated forum at: – you can add attachments and mark the thread as private if you wish.


    Er – I can’t see where to register or login. I can login with my FB login but this only allows me to comment on posts rather than to start a new topic on the forum.

    Plugin Author Brian Harris


    Sorry about that, I had overlooked adding the widget and linking to the registration page.

    Here’s direct link:

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘IE 8’ is closed to new replies.