Support » Plugin: Content Anchor Links » IDs Not Added to Headings

  • Resolved tangonovember

    (@tangonovember)


    The latest version of the plugin (1.6.1) has been added to a development site (non-public) running current version (4.9.6) of WordPress. ID’s are not being added to H2s, H3s in pages, and a fatal error message is generated (see below) when saving page as a draft or publishing.

    Any thoughts?

    Fatal error: Uncaught Error: Call to undefined function mb_convert_encoding() in /apps/cdlib/apache/htdocs/wp-content/plugins/content-anchor-links/xnau_WP_Headings_IDs.php:172 Stack trace: #0 /apps/cdlib/apache/htdocs/wp-content/plugins/content-anchor-links/xnau_WP_Headings_IDs.php(124): xnau_WP_Headings_IDs->prepare_slug(‘Lorem’) #1 /apps/cdlib/apache/htdocs/wp-content/plugins/content-anchor-links/xnau_WP_Headings_IDs.php(96): xnau_WP_Headings_IDs->make_slug(‘Lorem’) #2 [internal function]: xnau_WP_Headings_IDs->place_ids(Array) #3 /apps/cdlib/apache/htdocs/wp-content/plugins/content-anchor-links/xnau_WP_Headings_IDs.php(80): preg_replace_callback(‘%<(?<tag>h[2-6]…’, Array, ‘<h2>Lorem</h2>\r…’) #4 /apps/cdlib/apache/htdocs/wp-content/plugins/content-anchor-links/xnau_WP_Headings_IDs.php(63): xnau_WP_Headings_IDs->add_anchors_to_headings() #5 /apps/cdlib/apache/htdocs/wp-includes/class-wp-hook.php(286): xnau_WP_Headings_IDs::add_heading_ids(‘<h2>Lorem</h2>\r…’, ‘25300’) #6 /apps/cdlib/apache/htdocs/wp-includes/plugi in /apps/cdlib/apache/htdocs/wp-content/plugins/content-anchor-links/xnau_WP_Headings_IDs.php on line 172

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author xnau webdesign

    (@xnau)

    The plugin assumes the presence of the “mbstring” module in php. If you can install the module or ask your web host to install it the problem will go away.

    I will write this up as a bug so that it can deal more gracefully with php installs that don’t have this module.

    We are experiencing the same issue of ID’s not appearing after a save or publish. We are running WP 4.9.8, Content Anchor Links 1.6.1, and mbstring (7.1.23-1.34).

    We’re receiving the error: Invalid argument supplied for foreach() in /htdocs/wp-content/plugins/content-anchor-links/xnau_WP_Anchor_Links.php on line 107

    Any suggestions? Thx.

    Plugin Author xnau webdesign

    (@xnau)

    I’ll need to know about the circumstances. How are you publishing your post? What headings are you using in the post? Are you using any kind of plugin that changes the way posts are composed and published?

    Thanks for your response! We are using page templates with ACF fields for text using the standard Wysiwyg text editor. We are using h2’s, h3’s, and h4’s for the headings. Pages are saved/published in the standard way.

    Plugin Author xnau webdesign

    (@xnau)

    OK, the plugin is designed to work with the main post or page content, I have never tested it on rich text ACF fields. That shouldn’t be too hard to get working on my end, though. I’ll need to issue an update to cover that added functionality.

    Just installed the update and it works. Many thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘IDs Not Added to Headings’ is closed to new replies.