Support » Fixing WordPress » Idiot boy returns

  • I just need to leave my new install alone and enjoy the day, but I feel like I need to actually accomplish something first. Here’s the deal, over at http://x.babygotbooks.com I have thrown up a few test posts and an about us page. Then I had the crazy idea to change my permalink structure as follows: /%postname%/

    And now the links to the posts and about us page pull up a 404 error page. What gives?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Mark (podz)

    (@podz)

    Support Maven

    You need a little more in there …. imagine you keeping this blog going for a while and then breaking it because you make two posts, each with the same title.
    Better to have some more detail in there .. category .. date.

    And this isn’t idiot boy – it’s called ‘playing with the software’ and right now while you have less data, it’s the best time. Keep playing !

    3 things:

    Your server must support mod_rewrite.

    Your server must allow you to use a .htaccess file and allow it to be writable

    Somewhere in the Codex it says that you need a link structure that is more than just the name of the post. If you meet the other 2 requirements, then try including an some additional parameters, such as date, category, or whatever. It specifically states that some sites using only the post name will have the problems you are mentioning.

    We’ve been experimenting with pretty permalinks on a new site we’re setting up and have settled on just using the post number: “www.ourcoolsite.com/15/”. It’s not pretty, but it’s not ugly either.

    I am enjoying playing with the software, but it’s making me crazy. I have added the following to the structure:

    /%year%/%post_id%/%postname%/

    The stucture has changed accordingly and shows up when my cursor is on the link, but clicking on the link pulls up a 404. Since you, Podz, are more familiar with my setup than anyone (including me) – reading through some of the codex it sounds like I may need to make some changes to my .htaccess file. Is that what my problem is?

    Also, my web host assures me that mod_rewrite is installed.

    Mark (podz)

    (@podz)

    Support Maven

    I know as much about rewrite rules as I do something very obcure indeed.
    I assume the htaccess is being written to ….. it could be one of those rewrite rules oddities. Try putting category in there ?

    mod_rewrite allows several functionalities.
    Even if mod_rewrite is loaded, it does not mean rewriting url is allowed. Some host disable that functionality for security reason.

    The best way is to email your host with the generated permalink rule and ask them if the directive will work on the server.

    An option would be to prefix the structure with /index.php/, e.g,
    /index.php/%year%/%monthnum%/%day%/%postname%

    Also check out the Rewrite Plugin. It still needs to be able to write to your .htaccess file, but it does the whole rewrite thing differently.

    One other thing you might want to do is to take a look at your .htaccess file. Download it using ftp and open it up in a text editor. There should be a section called “# BEGIN WordPress”. If not, then WP isn’t able to write to the file.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Idiot boy returns’ is closed to new replies.