Support » Plugin: LifterLMS » Identical page different display

  • Resolved TheArtfulDodger

    (@theartfuldodger)



    I have 2 pages in my course which I have provided the links for:

    http://courses.dumagueteielts.com/lesson/intro-to-grammar-awareness/

    http://courses.dumagueteielts.com/lesson/lesson-comparatives/

    The issue is with the course syllabus sidebar.

    All of my lesson pages I have created CSS for and put in a border-radius and padding at the bottom.

    The problem is that the introduction page displays with square edges and no padding.

    CSS for grammar intro :

    .entry-title {
        font-size: 40px;
    
    .fl-photo-content img {
        display: inline;
        height: auto !important;
        max-width: 100%;
        width: auto !important;
        border-radius: 10px;
    }
    
    .fl-module img {
        max-width: 100%;
        border-radius: 10px;
    }
    
    .separate-containers .widget:last-child, .widget:last-child {
        margin-bottom: 0;
        border-radius: 10px;
    }
    
    .widget-area .widget {
        padding: 40px 40px 20px 30px;
         border-radius: 10px;
    }
    
    .separate-containers .widget, .separate-containers .site-main > *, .separate-containers .page-header, .widget-area .main-navigation {
        margin-bottom: 0px;
        border-radius: 10px;
    }
    
    #right-sidebar { padding: 40px 40px 20px 30px;
         border-radius: 10px;
     }

    CSS for comparatives page:

    .fl-photo-content img {
        display: inline;
        height: auto !important;
        max-width: 100%;
        width: auto !important;
        border-radius: 10px;
    }
    
    .fl-module img {
        max-width: 100%;
        border-radius: 10px;
    }
    
    .separate-containers .widget:last-child, .widget:last-child {
        margin-bottom: 0;
        border-radius: 10px;
    }
    
    .widget-area .widget {
        padding: 40px 40px 20px 30px;
         border-radius: 10px;
    }
    
    .separate-containers .widget, .separate-containers .site-main > *, .separate-containers .page-header, .widget-area .main-navigation {
        margin-bottom: 0px;
        border-radius: 10px;
    }

    [Moderator note: code fixed. Please wrap code in the backtick character or use the code button.]

    The only difference is the title text font size command which I am testing.

    Why are the 2 sidebars displaying so differently?

    Any help is appreciated.

    • This topic was modified 1 year, 5 months ago by  bdbrown.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Thomas Patrick Levy

    (@thomasplevy)

    @theartfuldodger,

    Looks like you’re using BeaverBuilder based on the fl prefix in your css. My guess here is that you’ve setup your pages slightly differently in BeaverBuilder (maybe it visually looks the same but you’re using different modules or something and, therefore, you need to modify the CSS to accommodate

    I’m blind though — LifterLMS lessons are not publicly visible (you need to be enrolled) if you can make the lessons “Free” (temporarily) I can see the issue and maybe help further.

    Thanks for your response.

    I have made the lessons free temporarily.

    do you need admin access? The site is not live yet so no problem if you do.

    Plugin Author Thomas Patrick Levy

    (@thomasplevy)

    @theartfuldodger,

    DO NOT POST ADMIN CREDS HERE!

    It looks like your CSS isn’t loading on the one lesson. How are you adding this custom CSS to your site?

    I’d recommend adding it as global CSS via the customizer so that it will show up across the whole site: https://lifterlms.com/docs/add-custom-css-using-wordpress-customizer/

    Hope that helps,

    @thomasplevy – Thank you for that emphasis.

    @theartfuldodger – Please do not offer to provide admin access to your site on these forums. The internet is a wonderful place full of very nice people and a few very bad ones. I’m sure everyone here is very nice however, by giving someone the keys to your house, you are trusting they won’t steal anything. Likewise, the person who takes the keys is now responsible for the house FOREVER. If you want to contact the author on his official support site to continue that discussion that’s up to you; just not here on the forums. Thanks for your cooperation.

    I wasn’t going to supply the information in the forum. I was going to use an alternative method.

    I will try altering the CSS and test it.

    Thanks.

    It worked a treat. Thanks.

    Plugin Author Thomas Patrick Levy

    (@thomasplevy)

    @theartfuldodger,

    Glad it worked. I have to add some emphasis re: creds because I’ve had people simply drop passwords into support forums here before and as @bdbrown has stated that lumps a lot of responsibility on our shoulders as the plugin maintainers…

    We do offer support via private tickets and email but only to paying customers. You can get premium (and expedited) support via LifterLMS Pro (or any addon) in ours store: https://lifterlms.com/store

    We do our best to help here but if you want us to look under the hood we won’t do it from here!

    Take care,

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Identical page different display’ is closed to new replies.