Support » Plugin: Freesoul Deactivate Plugins » Deactivate Plugin Paramenters

  • Resolved lgokul

    (@lgokul)


    ESTIMATED Mr Jose, as I said in previous posts your plugin is fabulous, here is another idea for your beautiful plugin.

    Disable plugin with url by parameters for example

    The plugin would be bbpress (example)

    www.example.com/shop/glasses (does not deactivate plugin)

    www.example.com/shop/glasses?ap (deactivates because I detect the “ap” parameter)

    www.example.com/shop/glasses?ap&oled (deactivated because I detect the “oled” parameter)

    I hope to be as clear as possible

    Thanks

    Edit: As an additional I see the update 1.4.3 but I do not see the change log, if it were so kind to indicate. Thank you!

    • This topic was modified 12 months ago by lgokul.
Viewing 10 replies - 16 through 25 (of 25 total)
  • Plugin Author Jose

    (@giuse)

    Hi @lgokul

    thank you very much for your useful ideas and for your translations!

    The CPU usage should be practically the same, I’ve performed many tests and haven’t noticed any CPU usage difference.

    Version 1.4.6 beta is ready. Before to publish it I would like to confirm it’s not slower on your installations. On my development installations after performing many tests, I can say the new version is only a couple of milliseconds slower, even settings hundreds of custom URLs.

    Version 1.4.6 has a little step backward regarding the custom URLs settings and some steps forward, first I want to be sure all work right also on your website, then I can provide 1.4.7 with further improvements regarding the custom URL settings.

    In shorts:
    – on the custom URLs settings, you can’t use anymore the star symbol “*”. What you write here will fetch the URLs if they are included in the loaded page URL, here some examples:

    https://homeurl.com/example/ will fetch URLs as https://homeurl.com/example/, https://homeurl.com/example/other-page/…

    /example/ will fetch URLs as https://homeurl.com/example/, https://homeurl.com/pages/example/…

    /pages/example/ will fetch URLs as https://homeurl.com/pages/example/, https://homeurl.com/pages/example/child-example/…

    ?example-paramameter=true* will fetch URLS as https://homeurl.com?example-paramameter=true, https://homeurl.com/page-example/?example-paramameter=true, https://homeurl.com/page-example/?another-example=something&example-paramameter=true…

    so you can’t set anymore something that looks like https://homeurl.com/*example*.

    Let me know if still notice a difference in terms of page loading time.

    – You can override the Seach options, but it’s for advanced users. You need to add this in your wp-config.php file for this feature:

    define( ‘EOS_DP_URL_APPLY_ON_SEARCH’,true );

    add it before the comment /* That’s all, stop editing! Happy blogging. */
    At the moment you have no options, only defining that constant will work.

    – About the debugging, if you add this line in your wp-config.php

    define( ‘EOS_DP_DEBUG’,true );
    (add it before the comment /* That’s all, stop editing! Happy blogging. */)

    then you will able to see the disabled plugins in your JavaScript console (right-click => inspect elements or F12 => console). I prefer to don’t show as default the disabled plugins, some users would not like everybody can see which plugins they have disabled and I prefer to don’t add weight to the code to allow only the admins.
    In any case, you will always see in the console the disabled plugins when you press the button “Test” on the Singles Settings. You also see on the bottom of the page the memory usage, the number of queries, the initialization time and the time needed to generate the page

    – 1.4.6 gives you the possibility to assign the URL settings priorities dragging and moving the URL rows

    you find here version 1.4.6: https://downloads.wordpress.org/plugin/freesoul-deactivate-plugins.1.4.6.zip

    thank you again for your valuable feedback.

    Dear Jose, I am delighted and grateful for your improvements but the “*” were very important since it allowed us to specify which pages to filter.

    From what I understood if I put https://homeurl.com/example it will also affect https://homeurl.com/pages/example but what happens if I want https://homeurl.com/pages/example have your own filter? and https://homeurl.com/example another?

    I don’t know if I let myself understand

    • This reply was modified 11 months, 1 week ago by lgokul.
    • This reply was modified 11 months, 1 week ago by lgokul.

    Currently I have configured the plugin with beta 1.4.5 and I am delighted.
    The detail would be that the “*” no longer work.

    As you can see each url has its filter configured differently according to the user

    *example.com/page/*
    *example.com/tienda/page/*
    */store/*/luz-led-*?geo*
    */store/*/*?geo*
    *example.com/categoria/*/page/*

    As indicated above the plugin gives priority to the 1st url and in that order it is applying the filters.
    Thanks for adding the arrows, but it is not a good idea to remove the “*” as it allows us to be deeper to specify which url to filter.

    Thank you very much for your time.

    • This reply was modified 11 months, 1 week ago by lgokul.
    • This reply was modified 11 months, 1 week ago by lgokul.
    Plugin Author Jose

    (@giuse)

    Hi @lgokul

    thank you for your information. I’ve removed the star “*” because I want to understand if it was slowing down your website. 1.4.7 will have improved custom URLs Settings.

    If you confirm 1.4.6 is not slower than 1.4.4, and 1.4.5 is slower than both 1.4.4 and 1.4.6, I will introduce again the “*” but I have to find a way to don’t slow down your website.

    • This reply was modified 11 months, 1 week ago by Jose.

    Dear Jose regarding version 1.4.5 I have good news, I am using it and doing well.
    I’ve been with her for 4 days and without mistakes.
    I installed the “Spider Blocker” plug-in since I saw my visitor record that a “YandexBot and BaiduBot” entered my site too many times. Apparently this caused error 508.
    The apologies of the case

    • This reply was modified 11 months, 1 week ago by lgokul.
    Plugin Author Jose

    (@giuse)

    Hi @lgokul

    perfect, I’m happy about this news, thank you very much for the information.

    You have again the star, the beta version 1.4.7 is available at https://downloads.wordpress.org/plugin/freesoul-deactivate-plugins.1.4.7.zip.

    If you confirm is all ok, I will publish a new official version.

    Sir Jose, I will try it on my real site and not on tests and I will tell you how it goes. Thank you very much for your time and knowledge.

    Dear Jose, I am with version 1.4.7
    The arrows come out but when I try to move it does not change place.
    Also implement: “define (‘ EOS_DP_URL_APPLY_ON_SEARCH ’, true);”

    And still not working in the search.

    Edit:
    define( ‘EOS_DP_URL_APPLY_ON_SEARCH’,true ); | it does not work
    —————–
    define('EOS_DP_URL_APPLY_ON_SEARCH',true ); | work!!

    Arrows already work after cleaning browser!!

    • This reply was modified 11 months, 1 week ago by lgokul.
    • This reply was modified 11 months, 1 week ago by lgokul.
    • This reply was modified 11 months, 1 week ago by lgokul.

    Everything works flawlessly! Thanks!

    Plugin Author Jose

    (@giuse)

    Hi @lgokul

    perfect, thank you very much!

    I will perform more tests. After confirming all works right I will publish version 1.5.0, it will be more or less as 1.4.7 beta.

    I will close this thread. If you have problems open a new one.

Viewing 10 replies - 16 through 25 (of 25 total)
  • The topic ‘Deactivate Plugin Paramenters’ is closed to new replies.