• Resolved japanoholic

    (@japanoholic)


    So after I updated your plugin now my social share icons have disappeared from my page. I have made no changes to the plugin and it happened after I updated. When I go to settings and tell the plugin to show the icons on every page nothing happens. I have the correct settings but still no icons show up.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author socialdude

    (@socialdude)

    Could you please clear cache? By that, I mean…

    – The browser cache, see https://www.solutionbay.com/solutions/dont-know-how-to-clear-the-cache-1
    – Please also check if you have a cache plugin installed. If so, please disable it temporarily, and check if it’s ok now

    Thread Starter japanoholic

    (@japanoholic)

    I have now cleared the browser cache and deactivated my LiteSpeed Cache plugin. Still no icons. I also deactivated my Google Analytics plugin as I updated it along with your plugin to see if there was a conflict. Didnt work either. I decided to rollback your plugin to the previous version and now I got my icons back

    Plugin Author socialdude

    (@socialdude)

    Ok, we clarified it. That the icons show on your homepage is actually a bug. Because you selected to show the after posts – not on your homepage. It’s a bug we fixed in the latest plugin version.

    If you want to also show them on your homepage, please use shortcode for example.

    Thread Starter japanoholic

    (@japanoholic)

    So I should manually add shortcode to 1900 pages in order to make them shareable? I think I prefer keeping the unupdated bug version since it allows me to keep my icons without issues. I don’t see it as a bug that I am able to share my homepage. Thats the point in having the plugin for me

    Plugin Author socialdude

    (@socialdude)

    Yes, you can do that also. We just had to correct it because it was a bug – users didn’t select to show it on their homepages, but it still showed there.

    If adding it to your posts/pages directly sounds daunting, just add the shortcode to the template/theme you are using:

    To use a shortcode in a page/theme template, simply wrap the standard WordPress do_shortcode function (created for this very purpose) with a little PHP coding – as follows (to be inserted wherever in the page/theme template file you’d like to enable your shortcode’s specific functionality):

    (php open closing brackets removed just in case 😉

    php echo do_shortcode(“[insert-your-shortcode-here]”);

    …remembering of course, to substitute [insert-your-shortcode-here] for the shortcode you actually want to use.

    Plugin Author socialdude

    (@socialdude)

    @shadowood Thank you for your support! 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Icons not showing anymore’ is closed to new replies.