Support » Plugin: Simple Social Icons » icons not showing

  • Hello. Updating a new Genesis theme with this plugin. The social icons aren’t showing. Instead blue squares show… See the Above Header Menu and the first box under the about on primary side bar to see what’s happening for our page.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi:

    I have a client with the same issue. A previous update fixed it but it appears a “new” update broke things again. Hope they respond back on what might be happening!! I ended up installing a different plugin that sort of gave me the same look.

    Thread Starter rieldealmarketing


    Thank you @masselyn – I’m hoping for a reply, too. Which plugin did you end up using as an alternate? I’d love to get something in place in the meantime

    I was having the same issue. I found a fix for me. I hope it helps. I use Godaddy Managed WordPress. I simply went and disabled CDN. I then checked in an incongnito window and the icons were all back. I then went and enable CDN again and the icons are still there! I hope this helps you!



    I am having this same issue. I tried the CDN fix, and although the icons were visible while the CDN was disabled, as soon as I reenabled it they were gone again.



    FYI for me this seems to have done the trick until a fix is available. In your CDN settings, put this in the box of URLs to exclude (mine is WP Rocket, your wildcards may be different):

    Hi MaryAnn, I’m glad that worked for you. On an other WP website, the CDN fix I mentioned before did not work. I had to delete the plug-in and I added the plug-in “Social Media and Share Icons (Ultimate Social Media).” I don’t like it as much but at least I can show my icons on that website now. I’m using the free version and you can see more on their website at They have 5 stars with 5,016 ratings and over 200K active installations.

    I have the same problem since the Genesis StudioPress Simple Social Icons Plugin was last updated to version 3.0.2 a little under a year ago.

    The Genesis Studio Press creator Brian Gardener sold out to WPEngine. The plugin has not been updated since then.

    I have posted this problem on the Genesis Studio Press FaceBook support page and expect it gets resolved ASAP. I will also try to post it on the GENESIS SLACK forum.

    The only solution for now is to exclude the plugin from your CDN thus:


    This hack regretfully slows down our websites as it cannot be cached on our CDN.

    I visited the Have To Host site and see you are not using a CDN. The icons look tiny on laptop.

    • This reply was modified 2 years, 4 months ago by belamer.
Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘icons not showing’ is closed to new replies.