Support » Plugin: Scriptless Social Sharing » Icons not showing

  • Resolved Alvaro Gois dos Santos

    (@alvarogois)



    Hi,

    Thank you for sharing your work.

    I’m having an issue with the buttons not showing icons. I’m not getting any error in the console, what could possibly be the problem?

    Thanks.

    Álvaro

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • I found that some option on WP Disable plugin is interfering with Scriptless Social Sharing. Disabling that brought back the icons.

    Now I have to figure out what’s the incompatible option.

    OK, I found it:

    • Minimize requests and load Google Fonts asynchronous
    • Minimize requests and load Font Awesome asynchronous

    Each one of this WP Disable options prevent SSS from loading the icons.

    Plugin Author Robin Cornett

    (@littlerchicken)

    Thank you for updating your thread with your findings; I really appreciate it!

    This plugin doesn’t use Google Fonts at all, so I’m not sure why that setting would affect the icons. It does use Font Awesome, though. If you are loading FA another way and would like to keep using the other plugin setting, you can prevent Scriptless from loading Font Awesome (via the Font Awesome CDN link) at all, and see if that helps. That’s a checkbox setting on the main Scriptless settings page.

    Again, thank you for the updates!

    I’m indeed not loading Font Awesome through SSS, GeneratePress theme already loads it. Nevertheless, that Minimize requests options from WP Disable kill the SSS icons (but not other Font Awesome icons though).

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Icons not showing’ is closed to new replies.