Support » Developing with WordPress » Icons not loading

  • Resolved sayedhussain96

    (@sayedhussain96)


    Hello Friends,

    I hope everyone is doing well.

    I have a problem on my site, that the icons are not loading when i first open the website as all of you will see when opening the link.

    can you please help, thanks in advance.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Please change your website url to https://darruaabh.com

    or install and activate plugin really simple ssl, it should solve your problem:
    https://wordpress.org/plugins/really-simple-ssl/

    Thread Starter sayedhussain96

    (@sayedhussain96)

    IT WORKED <3
    Thank you.

    The console log shows this error:

    Access to font at 'https://darruaabh.com/wp-content/plugins/elementor/assets/lib/font-awesome/webfonts/fa-solid-900.ttf' from origin 'http://darruaabh.com' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource

    It is a CORS issue.

    Do this:

    1- Login to your WordPress dashboard.
    2- Go to Settings -> General
    3- Find the settings -> WordPress Address (URL) and Site Address (URL)
    4- Make sure both settings has identical values. For example : * In your Site Address (URL), you have entered http://www.example.com
    * Make sure in WordPress Address (URL) input, you have entered http://www.example.com
    * A difference such as http and https or www will cause CORS issue

    • This reply was modified 1 year, 1 month ago by fakhriaz.
    Thread Starter sayedhussain96

    (@sayedhussain96)

    I did try your porposal but it was already the same.

    The plugin Really Simple SSL Fixed the proplem.

    Thank you Mr. vikas and Mr. fakhriaz

    AddWeb Solution Pvt. Ltd.

    (@addweb-solution-pvt-ltd)

    Hey @sayedhussain96

    I have reviewed your website and this is happening because of CROSS-DOMAIN origin. Cross-domain origin means your website is running on “HTTP” protocol and its try to access data from the “https” protocol and due to this reason icons are not loading in your website.

    Here is an screenshot for the same: https://tinyurl.com/y4w6dqj4

    Regards,

    I also face that kind of issues with my website of https://xxxtentacionmerch.net/ and the icons upload but not show in the live session. Cross-domain origin means your website is running on “HTTP” protocol and its try to access data from the “https” protocol and due to this reason icons are not loading in your website.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Icons not loading’ is closed to new replies.