Support » Plugin: Simple Social Icons » Icons not appearing correctly

  • Every single update I do I have to go into the the plugin editor and change these lines:

    @font-face {
    /* other stuff */
    url(‘../font/ssi-icomoon.woff’) format(‘woff’),
    url(‘../font/ssi-icomoon.ttf’) format(‘truetype’),
    /* other stuff */
    }

    to remove this: ?-texv9a

    I probably wouldn’t have to change both, but I do because I never took the time to figure out which font the plugin is using on my site:

    http://www.lilallergyadvocates.com

    I get why you’re doing this, but it’s clearly not working in my case. How can I avoid this? I’m not using a CDN and I’m not using any caching plugins.

    https://wordpress.org/plugins/simple-social-icons/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Nick Cernis

    (@modernnerd)

    Thanks for sharing this, ober0330. It sounds like your host could be using a piece of software called “ModSecurity” with a rule that blocks all requests if the query string starts with a hyphen (the ?-texv9a part).

    The next update to the plugin will fix this, so you will not have to amend the files after each update. Sorry for the inconvenience this caused.

    You’re welcome to monitor things after the next update, and get back in touch here if needed. (You’re also welcome to revise your review if all’s well, if you wish.)

    Thanks for the information. I appreciate the support and I will update my review.

    Plugin Contributor Nick Cernis

    (@modernnerd)

    Thanks, ober0330! Version 1.0.12 is out now with a fix for this issue, but do follow-up if you have any further trouble at all.

    Hello ober0330, thank you very much for the fix! I have been looking for a solution to this issue for several months now and what you suggest here worked. It is also clear that the most updated version of the plugin, one available as of this post, is still having the same issue.

    Hi, I’ve got version 1.0.13 installed, but I’m still not getting any icons to load. There’s this error when I look in the console:

    Resource interpreted as Stylesheet but transferred with MIME type text/html: "about:blank".
    [...]/wp-content/plugins/simple-social-icons/font/ssi-icomoon.woff?ssi-texv9a
    [...]/wp-content/plugins/simple-social-icons/font/ssi-icomoon.ttf?ssi-texv9a

    Any fix for this, besides manually editing the plugin files?

    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Icons not appearing correctly’ is closed to new replies.