Support » Plugin: Fast Velocity Minify » Icons missing on first load?

  • Resolved jockebq

    (@jockebq)


    Hi,

    This plugin is the best Minify-plugin I have found and everything works fantastic for me except one thing.
    The icons on first load are not shown, you can only see small boxes where they should be.
    Check here:
    https://imgur.com/a/4g3uS

    If I do an update they will be shown and everything works as expected. But not on first load when you haven’t visited the site for a while.

    It is not only the icons in the header, a few others on the front page have boxes instead.

    Any idea what to do about this. Problem is that some are defined in the styles.css file, which means I don’t want to exclude the whole file.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The same thing happens to me.

    Although my icons are drawn live on svg.

    Plugin Author Raul P.

    (@alignak)

    Hi,

    This is probably because there are multiple fontawesome icons loadeded.
    It could also be a merging conflict, try to play around with the ignore list.
    https://wordpress.org/plugins/fast-velocity-minify/faq/

    Thread Starter jockebq

    (@jockebq)

    Hi Raul, Thank you for the awesome plugin, fastest Minify I have tried.

    I have tried everything I can think of, but no success, everything else works fantastic with the plugin. Just that the first load doesn’t display fontawesome icons. After a second load or clicking to another page there is no problem.

    This is what I came up with in the ignore list:
    /wp-content/themes/mrtailor/inc/fonts/font-awesome/css/font-awesome.css
    /wp-content/themes/mrtailor/inc/fonts/font-awesome/css/font-awesome.min.css

    But no success, any ideas?

    Plugin Author Raul P.

    (@alignak)

    Does it happen if you inline all css?
    Are you deferring js?

    It looks like it’s either an animation issue with css due to merging, or a javascript jquery command that is being deferred.

    Does your icon fonts file show up in the header or footer of your html, when you add them to the ignore list?

    The FOUC effect happens when your font are not render blocking, or some effect is hiding it with an animation. Most of the time, is theme related.

    You can try to exclude your css files one by one, because it may not be the fonts file, but rather the theme styles, or something else.

    Thread Starter jockebq

    (@jockebq)

    Hi Raul,

    I have now tried the following:
    Disable CSS Processing, then Purge cache files and remove cache from WP Super Cache. After this opening the site with a new private windows. Same issue.
    Tried Disable JavaScript Processing, with the same result.
    And also HTML Minification.

    So nothing worked, and to make sure I also tried adding these folders to the ignore list:
    /wp-content/themes/mrtailor/inc/
    /wp-content/themes/mrtailor/css/
    /wp-content/themes/mrtailor/js/

    No success here either.

    So I tried your suggestions.
    Tried with “Inline all header CSS files” and “Inline all footer CSS files” activated. Same thing as before.
    I have not defer JavaScript activated, but I tried activating it without success. Also tried with Skip defer activated.

    Don’t know what you mean here:

    Does your icon fonts file show up in the header or footer of your html, when you add them to the ignore list?

    I tried adding a location to the ignore list and search the source from the browser, but couldn’t find it.

    So I am out of ideas?
    I really love this plugin as it works soo much better than everything else. But this problem is really annoying and takes away from the experience on first visits.

    Plugin Author Raul P.

    (@alignak)

    Wait, if you disable CSS processing and JS processing, it doesn’t fix it?

    When you tick those 2 options, it basically disables all features, except html minification completely, so it’s very strange it doesn’t work.

    Have you tried disabling the html minification too?

    I’m guessing your server is having some cache issues, because disabling those options and if you still see the same thing, something is cached somewhere.

    When you disable both css, js and html minification, purge the cache and then visit the homepage, do you see any uploads/fvm/cache/somefile.js or css file in the “view source” window?

    What theme are you using?
    What is your site url?
    What is your hosting company?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Icons missing on first load?’ is closed to new replies.