Support » Plugin: Amazon AWS CDN » Icons Missing After Activating The Plugin

  • Resolved seban_01

    (@seban_01)


    Hi sir, Iā€™m facing an issue after enabling CloudFront through our plugin. All the icons on the website including WordPress dashboard plugin icons show as a blank square(Screenshot-http://prntscr.com/mxt3dz). Any way to fix? Video play buttons are also showing as a square.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author luckychingi

    (@luckychingi)

    Hello @seban_01

    On my setup, I noticed that the icons disappeared when I enabled Elementor. I am still working on it and will keep you posted.

    seban_01

    (@seban_01)

    Great, Thank you so much for trying to help me. It means a lot to me <3

    Plugin Author luckychingi

    (@luckychingi)

    @seban_01 seems like the CORS Headers are missing on your web server.

    Can you confirm if the below code is present in your web server config?

    location ~* \.(ttf|ttc|otf|eot|woff|woff2)$ {
    add_header Access-Control-Allow-Origin *;
    }
    Plugin Author luckychingi

    (@luckychingi)

    @seban_01 any update?

    seban_01

    (@seban_01)

    I’m really sorry for replying late. I was out of town. I couldn’t find CORS headers in apache configuration. So I added it but doesn’t seem to change anything. Still, Icons are missing.

    Plugin Author luckychingi

    (@luckychingi)

    @seban_01 can you visit my site and email me, lets work outside the forum and post the resolution here.

    seban_01

    (@seban_01)

    @luckychingi : Email sent šŸ˜€ [support wpadmin.ca]

    Plugin Author luckychingi

    (@luckychingi)

    Issue resolved by @seban_01

    Thank you for your time.

    @luckychingi : Thank you so much for all your help. I didn’t receive this kind of prompt support from any other developers. You’re awesome. šŸ™‚

    I have the same problem, can you tell me how to slove it ??

    @ladiesman217 : You need to install mod_headers & CORS. My server has Nginx, Apache, Varnish web server. So here is what I did:

    In apache main config file (/usr/local/apache/conf/httpd.conf), add

    <IfModule mod_headers.c>
          Header set Access-Control-Allow-Origin "*"
    </IfModule>

    In apache domain vHost, add,

    <IfModule mod_headers.c>
        location ~* \.(ttf|ttc|otf|eot|woff|woff2)$ {
            add_header 'Access-Control-Allow-Origin' '*';
    }
    </IfModule>

    In Nginx domain vhost (/etc/nginx/conf.d/vhosts/yourdomain.com.conf), add.

    location ~* \.(ttf|ttc|otf|eot|woff|woff2)$ {
            add_header 'Access-Control-Allow-Origin' '*';

    If you have a different web server, google how to installs CORS.

    Thank you for your reply
    i will try to do it

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.