Support » Plugin: AddToAny Share Buttons » Icons don’t show on Firefox Browser

  • Resolved fran330

    (@fran330)



    Hi,

    On all my websites, the addtoany share icons (used in a widget) don’t show anymore on the frontend. The problems occured before I updated WP to 4.9 and still occurs after. So the WP update doesn’t seem to be the reason.

    On the other hand, it occurs since Firefox got updated to 57.0 on my PC.
    Maybe the problem has something to do with this ? (on Google Chrome, icons show normally / on Firefox on my tablet (not updated), icons show normally too).

    On my website’s backend, the Addtoany page shows this message:

    Something is preventing AddToAny from loading. Try disabling content blockers such as ad-blocking add-ons, or try another web browser.

    This doesn’t really help because we can’t ask website visitors to do special things in order to view the website properly…

    I hope you can help.
    Thanks in advance,
    Fran

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • duplografic

    (@duplografic)

    Hello, It’s happened to me too. How we can solve this? We can force it with CSS?

    Plugin Author micropat

    (@micropat)

    That can happen when Firefox’s “Tracking Protection” is enabled — it blocks major social buttons, and is off by default in Firefox’s regular browsing mode. You can toggle it as outlined here:

    https://support.mozilla.org/en-US/kb/tracking-protection

    If your site needs share buttons when that option is enabled, you can use the “Cache AddToAny locally with daily cache updates” options in Settings > AddToAny > Advanced Options.

    Thank you very much. I enabled the cache option in the settings and it works.
    🙂

    jp63

    (@jp63)

    I did too, but now I have only the rounded squares of the icons, without the typo or logos… in Firefox and Safari. With the cache option disabled, all is ok for Safari but nothing in Firefox.

    The issue is not only relative to the Tracking Protection. I can disable it on my computer, but not ask to all the visitors of my website to do it too.

    Thank for your help and advice.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Icons don’t show on Firefox Browser’ is closed to new replies.