Support » Theme: Virtue » Icons are not showing up properly on homepage

  • Resolved Konuku

    (@konuku)



    The links are located in the upper left hand corner. When I look at my website while I am in tweaking mode, it looks fine. But if I go to the website itself, there are only squares where there should be icons (home, Facebook, Linkedin, etc).

    Does anyone know how to fix this? Thanks.

    http://www.robinkickmw.com

Viewing 9 replies - 1 through 9 (of 9 total)
  • Thanks, but I am a total novice. What does it mean I need to put that code in the theme’s style sheet? Is that the CSS page? I have done that and it hasn’t seem to change anything.

    Thanks for your help.

    Yes, it’s style.css file.
    When you open font-awesome.min.css you can see following path:
    ‘Fonts/fontawesome-webfont.ttf?v=XX’ …
    It means that you have to create directory Fonts and then copy files fontawesome-webfont.ttf (fontawesome-webfont.woff, fontawesome-webfont.eot) to this folder. After that everything should work fine.

    Here’s another troubleshooting step:
    just put this in your .htaccess and it works:

    <IfModule mod_headers.c>
    <FilesMatch "\.(eot|font.css|otf|ttc|ttf|woff)$">
    Header set Access-Control-Allow-Origin "*"
    </FilesMatch>
    </IfModule>

    Note:TO edit .htaccess file you should connect to your hosting server provider with the FTP username, password and host name. You can use FileZilla for doing this.Now go inside your website’s directory and find .htaccess and put the above code I provided.
    Watch Tutorial for using FTP:
    https://www.youtube.com/watch?v=_nDQz1JQfYA

    Now upload the .htaccess file again. If you have any problem, reply me back.

    Thanks. I will try, but it all looks incredibly complicated to me. As I mentioned, I am only a novice. I download the free Virtue theme and do not know anything about coding or FTP. I am concerned that this is all way over my head.

    Links to social media seem like such a simple thing, so I am not sure what went wrong and why I need to go into special coding to fix it. 🙁

    But I will try.

    Good point, this question you should ask to theme developer.

    hannah

    (@hannahritner)

    Kadence Theme Support

    Hi Konuku,
    More than likely you just have a plugin that is conflicting with the theme. Try deactivating plugins one by one to test. Let me know if there’s no change.

    Hannah

    Hi Hannah,

    Thanks so much for your suggestion. I deactivated all the plug-ins and still have the problem. Any other suggestions?

    I really like your theme and cannot wait to transfer my blog over to it too.

    Cheers.

    Theme Author Kadence Themes

    (@britner)

    Hey,
    You have this error:

    1 Font from origin ‘http://ecbiz173.inmotionhosting.com’ has been blocked from loading by Cross-Origin Resource Sharing policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource. Origin ‘http://www.robinkickmw.com’ is therefore not allowed access.

    Means your loading the font through a url that isn’t the domain name of the size. You just need to make sure your site url inside the worpdress admin matches that url of the site. In your settings > general you should see the site url.

    Kadence Themes

    Yep. That did it. It seemed one had www. and the other not. Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Icons are not showing up properly on homepage’ is closed to new replies.