Support » Plugin: WP ULike » Icon not showing in summary pages

  • Resolved jlalonde

    (@jlalonde)


    Hi Alimir,

    First, thanks for this great plugin!

    I read the other thread about this issue and followed your recommendations. But I’m still having an issue after the upgrade to v2.8. The icons now only appear in the article pages (single). In the home page, archive, category pages, it displays only the number of likes and the area is not clickable.

    I cleared the cache and I do not use a CDN service. I’m using the SongWriter theme with WP v4.8. You can check it here: http://webradio.jeanlalonde.ca/category/blues/

    Thanks,

    Jean

Viewing 8 replies - 1 through 8 (of 8 total)
  • PS: I changed the “Auto Display Position” setting to “Bottom of Content”. I still appear in the single pages (at the end) but now do not show at all in the summary pages.

    Plugin Author Alimir

    (@alimir)

    Hi @jlalonde

    Did you enable some options in “Auto Display Filter”? (Also, I suggest you to reset the settings)

    Hi @alimir,

    > Did you enable some options in “Auto Display Filter”?

    No.

    > (Also, I suggest you to reset the settings)

    I did it for each tab (not sure if the reset was global or not). But the result is the same. I changed the “Auto Display Position” setting to “Top and Bottom of Content”. It is still OK in single posts but not in summary pages.

    Thanks for reply,

    Jean

    Plugin Author Alimir

    (@alimir)

    @jlalonde

    1- The reset is global for all options.
    2- I did not really find the summary pages on your site! Please describe with a URL or screen shot…

    * Also, give me a screenshot from your “WP ULike Settings > Posts” section.

    Excuse my English. By “summary” page, I mean all pages that show multiple posts, like home page, category page, etc.

    Example of the issue (on http://webradio.jeanlalonde.ca/):
    https://i.imgur.com/RM3zaUL.png

    https://i.imgur.com/4a236sV.png (top)
    https://i.imgur.com/ST3yCJx.png (bottom)

    Thanks,

    Jean

    Plugin Author Alimir

    (@alimir)

    @jlalonde

    Ok, I got it. For using the excerpt content on your summary pages, Our automated display filter does not work properly…
    In this situation you should use the following function in your content loop:

    if(function_exists('wp_ulike')) wp_ulike('get');

    * Don’t forget to filter home page option on the auto display filters.

    Done. It works. Thanks, Alimir! 5-star eval posted for support 🙂

    Marked as resolved.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.