Support » Plugin: AceIDE » Icon doesn’t appear in the dashboard

  • Resolved toshocorp

    (@toshocorp)


    Hello,

    Usualy I’m using WPIde and I don’t have any problem with it. Today I was building a new website and I installed WPIde but the icon didn’t appear. So I found and tried AceIDE. And the both icons didn’t appeared in the dashboard. I tried to install AceIDE on different site (with same wp version, theme and themeโ€™s version) and I didn’t have any problems (the icon appeared). Then I tried to install different plugin (on the problematic site) – Yoast SEO and the icon appeared. I even check the permission of the folders – 755. Also when I tried to open the plugin directly through mydomain.com/wp-admin/admin.php?page=aceide it’s says that I don’t have permission for that. What can be the problem and how to solve it? So in conclusion I can install and activate both – WPIde and AceIDE but the icons are not appearing.

    Thanks,

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author shanept

    (@shanept)

    Hi toshocorp,

    WPide requires the edit_themes permission. AceIDE requires the edit_plugins permission. Does your user account have those permissions? Have you changed the permission structure at all?

    Do you have the DISALLOW_FILE_EDIT constant defined?

    Do you have any sort of caching enabled?

    When you navigate to a URL like that, I’m pretty sure it will always say there is a permission issue when it should really be a 404…

    If you could try deactivating the other plugins to see whether there is a conflict, that would be great also.

    Kind Regards,
    Shane

    Thanks for the quick answer. I didn’t notice that “Editor” in Themes and Plugins was missing. The problem was that DISALLOW_FILE_EDIT constant (in wp-config.php) was set to “true” and I changed it to “false”. Now everything is working perfectly.

    Thanks for the help and sorry to bother you.

    On the bright side – from now on I will use AceIDE. ๐Ÿ™‚

    Plugin Author shanept

    (@shanept)

    Awesome! Glad it was an easy one.
    It is possible to get around it. There is a filter you can set if you wish, as follows:

    add_filter( ‘aceide_override_disallow_file_edit’, ‘__return_true’ );

    Just if that interests you ๐Ÿ™‚
    Glad we’ve sorted it. I’ll mark this closed now.

    Kind Regards,
    Shane

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Icon doesn’t appear in the dashboard’ is closed to new replies.