WordPress.org

Support

Support » Plugins and Hacks » [Resolved] ical not working

[Resolved] ical not working

Viewing 15 replies - 1 through 15 (of 18 total)
  • angelo_nwl
    Participant

    @angelo_nwl

    I tried this link http://www.ncridev.co.uk/events/csg-lymphoma/ and it works fine?

    jacktowner
    Member

    @jacktowner

    Thanks for the reply

    The URL works but the ical feed (next to the Google button) at the bottom of the page doesn’t.

    I did a clean install of WordPress and only installed the Events Manager plugin, and the /ical/ suffix seems to work on any single event, so probably not a problem with EM.

    DJLunacy
    Member

    @djlunacy

    Can you get the global list of events in the ical feed?

    Is it just the single events that the feed isn’t working?

    caimin_nwl
    NetWebLogic Support

    @caimin_nwl

    Have you tried re-saving your permalinks?

    DJLunacy
    Member

    @djlunacy

    Yes that didn’t work it just brings up ALL events in one ical file In the single event list. Instead of just the event you’re presently viewing.

    This is the code i’m using

    Add Event To iCal #_EVENTICALLINK

    jacktowner
    Member

    @jacktowner

    @djlunacy – yes, I’m using the same link as you
    @caimin_nwl – how do I do that?

    angelo_nwl
    Participant

    @angelo_nwl

    at WP Settings > Permalinks

    jacktowner
    Member

    @jacktowner

    my permalinks are set as Post name

    Philip John
    Member

    @philipjohn

    Given that your fresh installation worked fine it’s likely that a plugin or theme conflict is causing the iCal link to break.

    Try disabling all other plugins and reverting to the default theme to see if the problem disappears, then re-activate plugins to see which causes the link to break.

    Thanks

    jacktowner
    Member

    @jacktowner

    Thanks for the tip PhillipJohn – gave that a try and annoyingly still getting same 404 error.

    I only have a couple of events set up, so I think I’ll remove all the events using the dashboard, remove the offending plugin, remove any entries to ‘events’ in the wp_database. Hopefully that should be enough to clean any residual data, so I can do a ‘clean’ install, as I’ve tried reinstalling the plugin, but it remembers the events as they’re stored as custom post-types and not removed when the plugin is uninstalled.

    Cheers.

    Plugin Author Marcus
    Participant

    @netweblogic

    try the uninstall option whilst EM is activated in your plugins page.

    jacktowner
    Member

    @jacktowner

    Removing the database entries and reinstalling seems to have done the trick – thanks for the advice.

    Each event can be reached through event_url/ical or event_url/event.ics
    All events (including categories) through category_url/events.ics

    Great plugin, BTW. 🙂

    Cheers

    Plugin Author Marcus
    Participant

    @netweblogic

    glad you sorted it out!

    DJLunacy
    Member

    @djlunacy

    What’s a recommended fix, if you have many events and you simply can’t just remove the event data?

    In my case my theme doesn’t have anything to do with the Single event feeds not generating properly. It just does all at once.

    Plugin Author Marcus
    Participant

    @netweblogic

    @djlunacy not sure what you’re asking, but I’d raise a new thread on this

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Resolved] ical not working’ is closed to new replies.