Support » Plugin: Events Manager » iCal import problems

  • Resolved webmystery


    I’ve been having the same issue described in this post. It looks like it has been marked resolved as unreproduceable but with out any concrete resolution.

    The iCal imports form this site; give me this error:
    “The data downloaded from isn’t valid.”

    But iCal imports from the same version of Events Manager and WP from another site I manage, , work fine.

    No luck with the following troubleshooting methods:
    Switched to a generic template
    Replaced all of the Events Manger plugin files.
    Disabled all plugins except Events Manager

    Could it have something to do with the far greater number of events at I tried importing a single event. Same error with events from, but single events from work fine.

    I opened both events in a text editor and found that there are line breaks missing in the files. This is what broken event looks like in TextWrangler:

    SUMMARY:Third Thursday Jazz Nights - Koham Press - Thu\, Mar 20\, 2014 - 7:30 pm - 9:00 pm
    DESCRIPTION:Join Leo Cavanagh on Guitar and Guy Arrostuto on Piano\, for the first Third Thursday Jazz Night!\n\n$5 at the door - all proceeds go to the musicians!
    LOCATION:Koham Press

    …and this is a functional event

    SUMMARY:Buddha’s Birthday - Vallejo Zen Center - 5 Apr 14 00:00
    DESCRIPTION:Zazen at 9:30 AM\n\nLecture at 10:00 AM\n\nCeremony at 10:20 AM
    LOCATION:Vallejo Zen Center

    In the broken event the PRODID and BEGIN:VEVENT lines and the END:VEVENT END:VCALENDAR run together. When I break up those two items with a carriage return the event imports with no problem.
    (When I copied and pasted the broken event here the line breaks in the broken file appeared, so apparently those are the wrong kind of line break. TextWrangler shows an upside-down question mark there when I enable “show invisibles”.)

    Question is — Why is this happening and how do I fix it?

    Other differences between and uses a lot of different locations with the google map enabled; only has one location. events frequently have featured images, links to other sites and more verbiage; events are, well, simpler and more Zen.

    Thanks for any advise – I’d really like to get this to work.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Support caimin_nwl


    Assuming the Events Manager and WordPress versions are the same on both sites, is there something else that’s different? Maybe they use different server technology, for example?

    WP and Events Manager versions are the same (the one that works) is on GoDaddy is on a hosting server run by a local guy here in Benicia – – where i have a reseller account. I can actually walk in and talk to them if I need something changed:
    Apache version 2.2.26
    PHP version 5.3.27
    MySQL version 5.1.67-rel14.3-log
    Architecture x86_64
    Operating system linux

    What else might be relevant? – would the linux version or server config have something to do with the kind of line feed used? Why would only those two lines be affected instead of the whole .ics file?

    I’m tempted to try to find the relevant file in the plugin and hack it to change the type of line feed used – but I’m guessing it isn’t that simple.


    I see that in templates/ical.php there is a preg_replace command in both places where I’m seeing the problem line breaks.

    echo preg_replace("/([^\r])\n/", "$1\r\n", $output);

    Plugin Support angelo_nwl


    Have you tried to temporarily:

    – deactivating all other plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).
    – switching to the default theme to rule out any theme-specific problems

    Thanks, Angelo —
    Yes I tried both of those things as I mentioned above. I never post in support forums without trying basic troubleshooting first.

    Did you look at the other trouble report I linked at the top of my first post? I was also able to reproduce 286blue’s report of a warning from the validator “Line endings must be a Carriage Return/Line Feed (CRLF) pair.” I think I’m seeing the same bug. That issue was closed after 286blue stopped responding to Marcus’ questions – but no actual fix is mentioned. In that thread Marcus said he saw the problem but didn’t know how soon he’d be able to get to it.

    Plugin Support caimin_nwl


    What version of Events Manager are you using?

    Events Manager Version 5.5.2 – I made sure it was up to date and even deleted and replaced all the files before reporting here. WP is version version 3.8.1

    It works when I edit templates/ical.php, and change line 20 from this:
    to this:

    … and also line 80 from this:
    to this:

    Plugin Support caimin_nwl


    Ok, thanks. That indicates it’s a problem with new lines in the file when running on Linux. I’ll pass this along to the developers. Thanks again for the info.

    Plugin Author Marcus


    NetWebLogic Support

    Hi, was looking into this, but problem with your solution is it creates warnings when validating here:

    Whilst it might fix something for you, it may break something for others. I don’t think it’s linux-specific because we test on mainly on linux servers (e.g. the demo site), plus loads more people would be reporting this.

    Since we can’t reproduce it ourselves, if you can recreate this bug again and give us some access, we could have a closer look to see what the problem is.

    Thanks Marcus —

    That validator tool was gave the same warning about line breaks both before and after I added my solution, but the before version wasn’t working for me as two of the lines were running together. I’m happy to give you any access you’d like WP/ FTP/…? I only have to switch back to the default ical template to reproduce it.

    Plugin Author Marcus


    NetWebLogic Support

    sorry for the delay in getting back to you, we hadn’t forgotten! If you still have this problem, please go to our contact us page and send over some WP/FTP info and we can try it out ourselves.

    Please make sure you include a link to this page so we know who you are.

    We mainly test on linux so it’d be good to see it on a machine that has the problem.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘iCal import problems’ is closed to new replies.