WordPress.org

Forums

Latest Tweets Widget
[resolved] ";i:1;s:344:" and ";i:2;s:386:" (etc) above tweets (14 posts)

  1. rob@business-driven-it.co.uk
    Member
    Posted 1 year ago #

    Hello,

    I have installed your Latest Tweets plugin on 2 WordPress sites, including a site that I just use for testing. Both of them produce this 'Serialised Data' (I'm only assuming that's what it's called, because two previous posters refer to it thus).

    The problem is not consistent. The first time I display the page, it (usually) looks fine (but includes an odd 👍 'square' character). Further refreshes of the page (or visits from a different browser/machine) exhibit this problem.

    The problem is on both WordPress installations (both on 3.7.1).

    The problem appears to be related to a tweet which:
    - Was created on an iPhone;
    - The iPhone has the 'EMOJI' app installed;
    - The 'EMOJI' keyboard was selected; and
    - The user typed a 'thumbs-up' symbol as part of the tweet.

    I hope that this information helps you to troubleshoot the problem.

    Ta,

    Rob.

    http://wordpress.org/plugins/latest-tweets-widget/

  2. timwhitlock
    Member
    Plugin Author

    Posted 1 year ago #

    This problem has indeed been reported. The reason it hasn't been fixed is that I can't reproduce it.

    First of all the "👍" character is not a bug, it's expected behaviour when your font does not contain that glyph. If you need to display Emoji glyphs on systems without emoji fonts you'll need another plugin.

    Regarding the serialized data, this is almost certainly occurring when the data is pulled from a cache. (hence why it works the first time, but not the second). What caching is being used on your server? Do you have APC enabled? Do you have an additional caching plugin installed?

  3. rob@business-driven-it.co.uk
    Member
    Posted 1 year ago #

    My test server is a pretty much clean install of WordPress 3.7.0, upgraded to 3.7.1

    It has no caching plugin installed.

    The only changes from the vanilla install is the fact that I installed Media Library plugin and Twitter Widget Pro for testing (which is also broken by this Emoji character).

    Both web sites are hosted on the same provider, but I have (just now) tested it on a third web site on a different hosting provider and it still has the same problem.

    Thanks for your help,

    Rob.

  4. timwhitlock
    Member
    Plugin Author

    Posted 1 year ago #

    What is the twitter username you're using? I want to pull in your exact same feed.

  5. rob@business-driven-it.co.uk
    Member
    Posted 1 year ago #

    Sorry, I just realised that I didn't specify.

    I have tested on 5quidhost.co.uk and dreamhost.com

    Rob.

  6. rob@business-driven-it.co.uk
    Member
    Posted 1 year ago #

    The Twitter username with the problem post is: @benoittreluyer

  7. timwhitlock
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, well I've upgraded to WP 3.7.1 and disabled my APC cache and I still don't get the same error as you.

    As it happens there is a bug. WordPress cannot cache 4-byte Unicode strings (such as your Emoji character) However, in my case this just prevents caching; it doesn't display serialized data like you are seeing.

    What do you get if you pull a Twitter timeline without Emoji characters?

    I will look at implementing a fix that strips out any 4-byte characters, but I'd like to find out what the actual problem is with serialisation.

  8. rob@business-driven-it.co.uk
    Member
    Posted 1 year ago #

    If I pull a Twitter time line without Emoji characters, it looks fine.

    In fact, if I only pull 3 tweets of Benoit's, then it looks fine, because it is the fourth tweet that contains the thumbs up.

    I have tested in Chrome and Safari on a Mac. I will test under Windows too.

  9. timwhitlock
    Member
    Plugin Author

    Posted 1 year ago #

    no need to test other browsers, it's a back end problem.

    Although I don't understand why your cache is behaving differently to mine in the same version of WordPress, the issue is definitely the four-byte characters. I'm working to strip these out the tweet.

  10. timwhitlock
    Member
    Plugin Author

    Posted 1 year ago #

    I have tried a fix for this in the Development version
    http://wordpress.org/plugins/latest-tweets-widget/developers/

    This strips all four-byte Unicode characters out of a tweet before it's cached.

    Can you try it out and let me know if it fixes it, please?

    Note that if you have bad data already in your WordPress cache, you'll have to either clear it manually or wait for it to expire.

  11. rob@business-driven-it.co.uk
    Member
    Posted 1 year ago #

    Thank you. Let me know if I can help with the testing?

    I did test with Internet Explorer and Chrome under Windows. Both had the same problem, but IE was the only one to display the 'thumbs-up' correctly (but only the first time).

  12. timwhitlock
    Member
    Plugin Author

    Posted 1 year ago #

    Windows 8 supports Emoji, that's why. So does Safari on iOS and Mac OS Mountain Lion.

    You can help with testing by telling me whether the development version fixes your problem.

  13. rob@business-driven-it.co.uk
    Member
    Posted 1 year ago #

    Hiya,

    Sorry for the delay - working for another client today!

    Your development version 1.0.15 fixes my problem. Thank you.

    I will keep an eye out for the release version.

    I really appreciate your responsiveness. Fantastic service.

    Rob.

  14. timwhitlock
    Member
    Plugin Author

    Posted 1 year ago #

    1.0.15 is published to live now. Thanks for the feedback.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic