Support » Fixing WordPress » I woud like to change site name removing the /wordpress1

Viewing 9 replies - 1 through 9 (of 9 total)
  • Serge


    You need to edit your database and change the paths there.

    Back-up and download your database sql file, edit it with a text editor like notepad++, and change the paths from to

    In Notepad++ you have a function called Search and Replace where you can replace all the occurrences of a specific word/query on the entire document at once.

    Save the modifications, upload it back to your server.

    Move all the files from to the root of your account, in public_html.

    Check Administrator – Settings for the correct path.

    Have look on



    Hi Gholem

    Thanks for your speedy response.
    I’m in the process of wading through, adding more content at the moment.
    So will alter address hopefully on bare bones completion.

    What is the best way to back up my site.
    Is there a solid plugin that you would advise?
    Or is it something I do externally from WP?

    Newbie here so my questions are probably quite rudimentary.

    Thanks once again in advance.



    From my experience, the most efficient and rapid way to perform the backup is to do it from your hosting account, with what software they provide there.
    For example, I’m on Linux, with Cpanel. There are some tutorials available on how to do this:

    Now, depending on what’s your hosting operating system and what software you have installed there, this process may be different.

    As for plugins, if you find this way to be somehow easier, you could use this plugin .

    Also, have a read for the WP Codex advices, there are usually easy to understand and apply:



    Ah cool

    Learning more and more, evening editing bits of PHP now.(albeit simple)
    Really getting into the whole wordpress buzz.

    I know this is off topic but just clearing everything up before altering site address. I have just installed the plugin Yoast WordPress SEO

    It has given me this issue :
    Fix it.Ignore.You do not have your postname in the URL of your posts and pages, it is highly recommended that you do. Consider setting your permalink structure to /%postname%/.

    Now my permalink settings at the moment are on numeric.
    The (unchecked) custom structure reads /archives/%post_id%

    What is the best course of action?

    Thanks again in advance



    I’m glad you’re getting your hands dirty with WP, it’s a great platform to work with, incredibly easy to install, configure and manage and it has (or so I was made to believe) the biggest community of people behind it.

    About the YOAST plugin: this topic it’s not the place to discuss it. You should start another topic, particularly related to that plugin if you want help/advice about it.
    I’ve just started using YOAST plugin myself and I’m afraid I don’t know enough about it to help you out with its settings. And there’s also a thing of problems division, WP is WP, WP plugins are another story and most of the time the plugin creator has the answers, not the community.

    Anyways, just to get this out of the way, setting the permalinks to /%postname%/ (would look like is usually a good thing, please have a look here, here, here and here.

    Don’t take their word for everything, but do learn how seo works and why it’s good to have human readable urls. It’s a fantastic world of which you’ll never get enough once you start to understand the whys and the hows.

    Also, please have a look at the WP Codex explanations and usage:

    (You can take these guys’ words for what they say. 🙂 )

    Hi Gholem

    Thanks for all your help.
    I’m really enjoying my WordPress experience so far.

    My initial objective was to use it for an easily maintained approach to a portfolio site but I am now hooked. I want to expand it into a Blogfolio so part is static and the other is a quick changing blog refllecting current design and trends.Using WordPress to expand a social media framework for me is really useful.

    Thanks again
    Kind regards

    You’re most welcome, @sanct !

    I hope you’ll find all the needed help, ideas, suggestions and tools around here.

    Just search for the problem you might have and see if someone already solved it. If not, start a new topic and present your problem in a coherent way, stating:

    • your WP version
    • your active theme
    • plugins and third party scripts you have installed
    • your (dashboard) settings
    • the wp-config.php file in the root directory
    • the .htaccess file in the root directory
    • provide your blog/website address, if necessary
    • your hosting details (avoid ad-like formulations but trashing as well)

    This way you can help the others understand in what environment your installation works and have a better approach to your problem.


    Hi all

    I decided to take the plunge and change my front title page to the above mentioned removing the /wordpress1.

    So went to my PHPMyAdmin and performed a search and replace using.

    UPDATE wp_posts SET post_content = REPLACE (
    ‘Item to replace here’,
    ‘Replacement text here’);

    erm a little too much confidence me thinks.
    I have e now spent the day trying to fix my site.

    It’s hosted through Godaddy and everytime I try to restore my database it just leaves a window saying restoring and locks.

    I have a complete site back up on my hard drive and another on Online Backup for WordPress.

    Could anyone help by giving me a straight forward guide to the quickest way of fixing this, including any removal of screwed database etc before restore. I am at my wits end!

    Many tired thanks in advance

    after many hours of panic and thinking the DB wasn’t restoring I managed to sort the problem.

    I needed to update the connection strings in the wp-config.php file

    /** The name of the database for WordPress */
    define(‘DB_NAME’, ‘putyourdbnamehere’);
    /** MySQL database username */
    define(‘DB_USER’, ‘usernamehere’);
    /** MySQL database password */
    define(‘DB_PASSWORD’, ‘yourpasswordhere’);
    /** MySQL hostname */
    define(‘DB_HOST’, ‘localhost’);

    Contained was an incorrect password.
    An old password that had been long since changed.
    Very odd!

    The good news is everything is back up and running.
    I am now very scared to try the URL change again.
    Any thoughts?

    Happy, happy man 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘I woud like to change site name removing the /wordpress1’ is closed to new replies.