Support » Plugin: BAN Users » I wonder when this plugin will be updated.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author webxmedia

    (@webxmedia)

    Hi Doogis, thanks for your message and sorry to keep you waiting. I’ve been working on a new release of both the free and paid plugin which has taken a little long than anticipated, partly because of work commitments. The new releases are however due out this month so I will email you back once they are live.

    Thanks for your patience.
    Matt

    Plugin Author webxmedia

    (@webxmedia)

    Hi doogis,

    For your awareness I’ve just released an incremental plugin update which now includes the ability for you to restrict access to the ban user functions. So you can prevent users from banning same roles, roles that are higher or only allow them to ban users with a lower role. Please let me know how you get on and if you have any questions or issues.

    Matt.

    doogis

    (@doogis)

    Thanks for the update
    But I found some errors.

    Super administrator privilegesRegardless of the rating setting for a van, the Super Administrator must be able to do the vanCurrently, if you set a rating, you can prohibit only that rating

    As a second error, the strange code “<! <! <! <! <! <! <! …” appears in the WordPress user list window.

    Plugin Author webxmedia

    (@webxmedia)

    Thanks for the feedback doogis. I will take a look at the code that’s appeared in the user list window. I’m not sure I fully understand your query about the Super Admin rights. Are you saying that you want to restrict the ability to ban users to just SuperAdmin users? Or that if you do restrict banning to a particular group of users that the SuperAdmin must still always be able to ban/unban a user. If you can confirm that would be great.

    doogis

    (@doogis)

    Thank you for your quick response.

    I uploaded a screenshot that shows strange code.
    URL: https://imgur.com/qZah8Rm

    By default, this test has been run with administrator ratings.
    We have created a “Grade 0” rating to ban users.
    Below is my settings screen.
    URL: https://imgur.com/gFPCor6

    Administrators must be able to use the “Ban User” feature regardless of whether or not this setting is registered.
    The above-mentioned “Level0” is an employee, not an administrator, and there is a problem that an administrator can not use an employee’s functions.

    • This reply was modified 2 years ago by doogis.
    • This reply was modified 2 years ago by doogis.
    Plugin Author webxmedia

    (@webxmedia)

    Hi doogis,

    Many thanks for those screenshots, they were most helpful. I’ve just released ver 1.5.0 of the plugin which fixes the “strange code” appearing above the user table. I’ve also added in a new feature which I think addresses you’re particular needs. Under the security settings you can now set the following option: “Always allow super admins/admins to perform ban/unban tasks regardless of any security restrictions”

    This then ensures the super admin/admins always have access to ban/unban users regardless of restrictions. I’ve also fixed a few issues.

    Let me know how you get on, cheers.

    doogis

    (@doogis)

    Thank you for a quick update
    I have verified that everything is working as normal.
    Thank you very much.

    Plugin Author webxmedia

    (@webxmedia)

    HI Doogis,

    Thanks for the feedback. I’ve just released another update (v1.5.1) in order to make the restrictions more flexible so wanted to make you aware as it will affect you. Now you can specify multiple users who are able to ban other users, as well as defining which user roles can be banned. So for example you could allow both Level0 and Authors to ban users in either the Editor or Subscriber roles.

    Any problems please let me know. Welcome any feedback.
    Matt

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘I wonder when this plugin will be updated.’ is closed to new replies.