WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] I was trying to install the Import feature under Tools

[Resolved] I was trying to install the Import feature under Tools

  • I was trying to install the Import feature under Tools. Then the following error message appeared: “Before you can upload your import file, you will need to fix the following error:

    Unable to create directory wp-content/uploads/2012/11. Is its parent directory writable by the server?”. Because of this error message,I was unable to complete the installation of the Import feature. Please advice what I should do next.

Viewing 3 replies - 1 through 3 (of 3 total)
  • esmi
    Forum Moderator

    @esmi

    Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.
    http://codex.wordpress.org/Changing_File_Permissions

    Hi esmi, thank you for your help. At first I tried 766 but there was still an error message. Then I tried 767 and the problem was solved. As suggested by you, I have changed it back to 755 and everything is normal. Thank you for you fantastic response to my post for help.

    By the way, I have previously posted in 2 other posts seeking help about my being unable to change from Default permalinks to Post-name permalinks. I have tried changing the permission of .htaccess file to 666 and now I have converted all my posts to Post-name permalinks successfully. I have also changed back to 644. Thanks for your suggestion to change permissions.

    Problem resolved. Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] I was trying to install the Import feature under Tools’ is closed to new replies.