Support » Fixing WordPress » I Upgrade Database then schema fatal error

  • Resolved zomoon


    Logged into the wp/admin and was greeted by a message saying I need to update my database, when I did I now get the message:
    Fatal error: Call to undefined function is_main_network() in /homepages/36/d120614115/htdocs/wp-admin/includes/schema.php on line 564
    The site is still online, but I cannot log into the dashboard at all.
    Really grateful for any help.

Viewing 9 replies - 1 through 9 (of 9 total)
    1. Use FTP to access your site
    2. rename all plugins by putting a ‘0’ in front of each plugin -folder;
    3. Check if the access / ‘normal functioning’ has been restored
    4. If so: one-by-one, remove the ‘0’, checking every time to see if the problem re-occurs.
    5. when the problem re-occurs, you’ve found the source of the problem; Delete and find a similar plugin that works with your site
    6. alternatively: FTP:Delete; Then download and install / activate a NEW version of the problematic plugin and see if this works.

    Instead of ftp, use the webaccess dashboard functions provided by the webhost.
    This usually is not as versatile and more cumbersome.

    Thank you so much for your help. However I am still having the same problem, I get this when I try to log in:”Database Update Required

    WordPress has been updated! Before we send you on your way, we have to update your database to the newest version.

    The update process may take a little while, so please be patient.

    Update WordPress Database”

    Then after I click the update I still get the same Fatal error message.

    I only had the akismet plugin installed, I used Dreamweaver and edited the file on the remote server, is this right? I added an 0 to the file name eg:0plugins.php I even went and deleted the plugins files, then the folders too (backed them up) and still the same result.
    Really appreciate anymore help thank you for your time.

    Only rename the pluginFOLDERS; DoNOT rename ‘plugin.php’ or any individual FILES, to do this test.

    Restore things to the previous situation, and then try the avove suggestion again.
    Make sure you refresh the browser after making these changes: <CTRL-F5>

    == == == alternatively
    If you still have access to the dashboard, RE-RUN THE UPDATE MANUALLY:

    Dashboard > updates > press ‘re-install now’ and follw instructions
    [fingers crossed 😉 ]

    == == == other
    Should you be running a ‘cache-plugin’, disable it, before updating.
    Then re-run the update manually. When things are OK, re-activate the plugin

    Let me know how this goes…

    Hi W.P.Ginfo
    I tried as you said with the 0plugins folder, refreshed and nothing changed. I only have the hello.php and index.php files in the plugin folder, and I can’t access the dashboard.

    Hi Rajesh_P_ I think you are supposed to start your own thread after searching the forums, good luck!


    1. Manually update:
      Download a fresh version of WP and unzip
    2. FTP: copy ‘wp-config.php’ to your PC
    3. FTP: upload te fresh copy of WP to your site; OVERWRITE!
    4. UPLOAD ‘wp-config.php’ from PC to site; OVERWRITE
    5. BROWSER: <ctrl-F5> refresh your browser
    6. check access to your dashboard

    I did this but it hasn’t worked. Would starting with a whole new wordpress saving my themes and css etc be worth trying?
    It did all work okay for months, just went wrong when I updated.

    Thank you so much for helping

    Hi I did fix the problem, started a new wordpress, new database and just transferred the theme and css etc.

    Thank you so much for all your help @w.P. Ginfo 🙂

    You’re welcome. I’m glad you’re site is OK now.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘I Upgrade Database then schema fatal error’ is closed to new replies.