Support » Requests and Feedback » I try localization but nothing change

  • I am new to wordpress.
    I host my blog on and blog was installed autonatically.
    Then I try to use my language [Traditional Chinese] in my blog.
    1. I put a in /languages inside /wp-includes
    2. I change define (‘WPLANG’, ‘zh_TW’); in wp-config.php
    But nothing change.

    I already try 6 hours again and again can anyone hlep me find the problem?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Changing the language should apply immediatly if your site is not cached by anything in between. So there is typically no need to wait 6 hours.

    Maybe you used the wrong case for the letters of the file name? An URI would help.

    You could also take a look at this post:
    the poster had similar issues until realized it was a permissions problem.

    I check over 30 times every step is correct.
    And blog is working but language is incorrct.
    The following I also read and set files 755 but still noting change.
    Then I try Simple Chinese but still nothing change.
    Is it possible the problem is come from the host? [i.e. they only support Englsih system?]

    I even try wordpress[Chinese version] directly cover all my original blog file. But my blog still in English, nothing change. Why so difficult to change language.

    Try another 3 language never work.
    I start to think it is the problem of host side.

    did you resolve this problem.
    now i am in this trouble also.
    I have to computer
    the one is freebsd 6.0+apache 2.0.55 + php
    use the zh_CN is good
    the other is freebsd 6.0 + apache 2.0.55 +php else
    use the location is bad.

    please help

    I just tried to move my blog to bluehost and had the same trouble. I googled for a solution and found out that a lot of people have had the same experience. Someone sent bluehost a help ticket for that and here is their reply:

    I am sorry but we can not provide support for third party programs. This is a wordpress bug, I suggest you contact work press about help with their product.

    Please be aware that we can not normally provide support for a 3rd party program, however I have seen this issue before with wordpress and it may help you to know this is a bug with their MAGIC1 and MAGIC2 variables in the gettext.php file. You are using a custom install of workpress so I can not say this will solve the issue for sure, but replacing the $MAGIC1 line with:

    $MAGIC1 = 2500072158;

    and the $MAGIC2 line with:

    $MAGIC2 = 3725722773;

    may solve this problem for you.

    It seems that some users did as the reply said and it worked, but it didn’t work for me. If it’s really a bug, maybe the wordpress group could try to fix it?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘I try localization but nothing change’ is closed to new replies.